
          

                          Sound Metrics Corp. 

1                     Using sound to make sound measurements 

 
 

 
 

Dual-Frequency Identification Sonar 
DIDSON 

 
Software Manual V5.26 

28 August 2017 

Manufactured by Sound Metrics Corporation 
11010 Northup Way      

Bellevue, WA   98004 
(425) 822 - 3001     Office 
(206) 374 - 2929       FAX 

 
Sales by Ocean Marine Industries Inc. 

2810 Hudson Street 
Chesapeake, VA 23324 
(757) 382 - 7616    Voice 
(757) 382 - 5012     FAX 

 
www.soundmetrics.com 



          

                          Sound Metrics Corp. 

1                     Using sound to make sound measurements 

 
 

 
 
 
 

Dual-Frequency Identification Sonar 
DIDSON 

 
Software Manual 

 
Use with firmware revision 6-18 or higher 

 
 
 
 

Table of Contents 
 
 
 

1 COMMAND SUMMARY ................................... ......................................................... 1 

1.1 MENU/TOOLBAR COMMANDS .............................................................................. 1 
1.2 SONAR CONTROLS ........................................................................................... 76 
1.3 DISPLAY CONTROLS ......................................................................................... 78 
1.4 REAL-TIME MOUSE CONTROL OF THE IMAGE WINDOW ......................................... 79 
1.5 FILE HEADER ................................................................................................... 79 

 



 

 1

1 Command Summary 

1.1 Menu/Toolbar Commands 
 
Menus are listed at the top left of the screen and from left to right are File, Edit, View, Image, Sonar, 
Processing, Aux and Help .  Toolbar icons are in a row just below the menus.  They allow shortcuts 
to many of the menu commands.  Some commands also have a keystroke alternative.  For example 
opening a new file has three alternatives:  1) Click on File , then click on Acquire Data,  or 2) Click on 
the Sonar Ping  icon, or 3) press the keystroke Ctrl+A .  These alternatives are listed with the File -
>New definition in the summary below. 
 
 
File Menu 

Acquire Data Keystroke: Ctrl+N  Toolbar Icon:  
 
Use this command to close any currently displayed image files and restart real-
time image acquisition and display from the DIDSON sonar. 
 

Open  Keystroke: Ctrl+O  Toolbar Icon:  
 
Open a previously stored file for playback. 
 

Previous Keystroke: None  Toolbar Icon:  
 
Left-click:   when a .ddf  file is opened, a complete list of .ddf files contained 
within the current folder is saved.  This command opens the previous file from 
that list, relative to the currently open playback file. 
 
Shift-left-click:   when an .ech file is opened, a complete list of .ech files 
contained within the current folder is saved.  This command opens the previous 
file from that list, relative to the currently open playback file. 
 

Next  Keystroke: None  Toolbar Icon:  
 

Left-click:   when a .ddf  file is opened, a complete list of .ddf files contained 
within the current folder is saved.  This command opens the next file from that 
list, relative to the currently open playback file. 
 
Shift-left-click:   when an .ech  file is opened, a complete list of ech files 
contained within the current folder is saved.  This command opens the next file 
from that list, relative to the currently open playback file. 
 

Save  Keystroke: Ctrl+S  Toolbar Icon:  
 
Save the file currently opened for playback to itself. Use this command to 
truncate a long file to a desired frame range, or to retain changes made to the 
Header ID field, or other editing tasks such as the additional of audio notes. 
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Data frames collected in real-time are saved when the record button is pressed 
(see Image->Capture->Record, Image->Capture->Record Options, and Image-
>Capture->Timer Recording for more information on various recording modes). 
 
See Set Endpoints, under the Image->Playback sub-menu, and the File->Save 
Options sub-menu for additional possibilities using this command. 
 
Default file name examples: 2001-06-26_#003_HF.ddf (using sequence 
numbers) or 2001-06-26_1745_HF.ddf (using current time). 
 

Save as Keystroke: None  Toolbar Icon: None 

If you choose .ddf as the file type (default), you will save the currently opened 
file to a new filename.  If you choose .avi, you will save the current movie (with 
current endpoints) in an .avi format. This will allow you to play the movie on 
other machines without requiring the DIDSON software.  The .avi files can be 
huge. You can crop the image by drawing the measure rectangle around what 
you want to save (see Measure under Display Controls) . Also, be sure to set 
the endpoints to cover only the time (frames) you want.  The third file type 
option is for compressed files (.zip); you will be prompted for choices on 
bundling audio files and/or moving the source file into the .zip file if these flags 
are not already set in the File->Save Options sub-menu. 
 
Another option for making avi files is to use third party software such as 
SNAGIT® during file playback. 
 
The current display settings for Threshold and Intensity are written to the new 
file, and will be set accordingly when opening the file if both the Image-
>Configure->Auto Threshold/Intensity and Image->Configure->Reset Frame 
Rate flags are checked. 
 
There is an option to save motion corrected data to .ddf files when using this 
command.  If motion correction is enabled the user is prompted whether to 
apply same to the saved data.  The force velocity value is used if the manual 
override flag is set in the PMC Parameters dialog, otherwise the velocity is 
taken from the frame header as for displayed data. 
 
If the Image->Capture->Record Options->Save Only Displayed Data flag is set, 
then the playback file will be saved with the displayed image data overwriting 
the default raw data samples, preserving the output of any enabled processing 
functions, such as Background Subtraction and Detect Motion. 
 

Set Save Keystroke: None  Toolbar Icon: None 
Directory 

Set the working directory (folder) for saving .ddf files.  Also gives the option of 
replacing the default _HHMMSS in the filename with a sequence number 
_#NNN, and sets a flag to append (or not) the frequency designation (_LF, 
_HF) to automatically generated filenames. 
 

Set Aux File Keystroke: None  Toolbar Icon: None 
Dir to… 

Controls the location of auxiliary files, such as fixed backgrounds, fish 
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counts, depth profiles, and JPEG output.  If Image Open Dir is selected, then 
the files will be saved to the same folder as the image file currently (or last) 
opened for playback.  Selecting Image Save Dir causes these files to be saved 
to the folder set with the File->Set Save Dir\Name command (defaults to 
C:\Didson Data).  If a file is opened from a read-only source such as a CD, the 
auxiliary files are automatically directed to the current save directory. 
 

Print  Keystroke: Ctrl+P  Toolbar Icon:  
 
Print the image with header information (local printers only).  
 

Recent Files Keystroke: None  Toolbar Icon: None 
 
The four most recently viewed files are listed and may be opened. 
 

Exit  Keystroke: Ctrl+X  Toolbar Icon: None 
 
Exit the application. 
 

 
Merge Sub-Menu 
 

Use these commands to stitch together a sequence of individual files for further 
processing on the entire image record, such as when recording to a local hard 
drive in Autonomous mode, or to save 24 hourly files to a full day’s record.  The 
base filename and path are as specified by the File->Set Save Directory 
command.   

 
All Files to Keystroke: None  Toolbar Icon: None 
New File 

Combine all files in the current (or last) open folder to a new .ddf file.  The 
identifier  _Merged is inserted before the optional frequency designation string 
(_LF, _HF). 
 

Append Open Keystroke: None  Toolbar Icon: None 
File to Existing 
File  Append the file currently opened for playback to an existing .ddf file.  Use this  

command to piece together image files from different folders (or the same 
folder) into a single image file. 
 

Selected Files Keystroke: None  Toolbar Icon: None 
to New File 

Combine any subset of all files in the current open folder to a new .ddf file.  A 
range of files may be selected by clicking the first file in the File Open dialog, 
then Shift->clicking the last file in the range.  Files may be added to or deleted 
from the list by Ctrl->clicking on individual filenames.  The identifier  _Merged is 
inserted before the optional frequency designation string (_LF, _HF). 
 
If the File->Save Options->Move Files flag is set, the original file(s) will be 
deleted after merging to the new or existing image file. 
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Save Options Sub-Menu 
 
Bundle Audio Keystroke: None  Toolbar Icon: None 
 

Set this flag to add all files starting with the currently open image file base name 
when compressing to a .zip file (i.e. the zip file would contain ImageFile.ddf plus 
ImageFile_Audio[000..nnn].mp3 (or other audio file type) files).  This flag works 
in concert with the File->Save, File->Save As, and Image->Capture->Record 
commands.   
 

Compress Keystroke: None  Toolbar Icon: None 
 

Set this flag to compress the currently open image file to a .zip file when saving.  
This flag works in conjunction with the File->Save, File->Save As, and Image-
>Capture->Record commands. 

 
Move Files Keystroke: None  Toolbar Icon: None 
 

Set this flag to delete the original source file(s) when compressing to a .zip file.  
This flag works along with the File->Save, File->Save As, and Image->Capture-
>Record commands.  Selecting a compressed file with File->Open will 
automatically extract the compressed file(s) to the same folder, and open the 
contained image file (of the same file name) for playback. 

 
Prompt for Keystroke: None  Toolbar Icon: None 
Avi Compressor 

Set this flag to prompt for a choice of codecs when converting a .ddf file to a 
.avi file with the File->Save As command.  When this flag is unchecked the 
default Microsoft Video 1 codec is used.  Some codecs, though present on the 
computer, may not work with the .avi conversion library functions, in which case 
you will get an error message. 
 

VERSION_ Keystroke: None  Toolbar Icon: None 
DDF_03 

Set the recorded file version to VERSION_DDF_03.  This version has a 512-
byte master header, followed by frame data with each frame starting with a 256-
byte frame header.  Selecting this version while connected to the sonar will also 
direct the sonar to record internal files in VERSION_DDF_03.  This is the 
default file version, compatible with all earlier Sound Metrics topside software. 

 
VERSION_ Keystroke: None  Toolbar Icon: None 
DDF_04 

Set the recorded file version to VERSION_DDF_04.  This version has a 1024-
byte master header, followed by frame data with each frame starting with a 
1024-byte frame header.  Selecting this version while connected to the sonar 
will also direct the sonar to record internal files in VERSION_DDF_04.  This is 
used when larger headers are required to store auxiliary (non-image) data, and 
also allows for a variable number of samples per channel (e.g. variable frame 
lengths) for future hardware upgrades. 
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Edit Menu 
 
Header ID Keystroke: Ctrl+H  Toolbar Icon: None 
 

Enter or change the Header ID string (256 characters maximum) for the 
currently opened file. Also, enter or change one to four user-named data 
constants. The default labels are User1…User4. You may change the labels as 
well as the constant values. The labels are stored in the DidsonAppV5.ini  file 
and reappear the next time the application is called.  The data for these fields 
are interpreted as 32-bit integers and stored in the file header. 
 

 
 

Application Sub-Menu 
 
Load App Keystroke: None  Toolbar Icon: None 
Settings 

This command loads all parameters stored in the DidsonAppV5.ini file from a 
user-specified file (see Application Initialization  section). 
 

Save App Keystroke: None  Toolbar Icon: None 
Settings 

This command saves all parameters stored in the DidsonAppV5.ini file to a 
user-specified file (see Application Initialization  section). 
 

Restore App Keystroke: None  Toolbar Icon: None 
Defaults 

This command resets all parameters stored in the DidsonAppV5.ini file to 
system defaults (see Application Initialization  section).  It also resets the 
application window size and position to default values. 
 

Joystick Keystroke: None  Toolbar Icon: None 
Buttons 
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Map joystick buttons to sonar control functions as seen below.  If the joystick 
buttons are not numbered and no manual is available, try each button in Demo 
Mode to see which button corresponds to a given number.  Setting the number 
to 0 for a given function will disable that function via joystick control. 
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Keymap Keystroke: None  Toolbar Icon: None 
 

Displays a dialog showing keystroke commands to change window length, 
focus, etc. The keys are active only after the left (control/display) window in 
sonar display has been “clicked” with a mouse so that it is “active.” 
 

 
 
 

 
Control  Keystroke: None  Toolbar Icon: None 
Enables 

Displays a dialog allowing individual sonar and display controls to be enabled or 
disabled to customize or simplify the look of the control window. 
 

Mode Sub-Menu 
 
Master  Keystroke: None  Toolbar Icon: None 

 
If checked, the application will allow the user to control the sonar. 
 

Slave  Keystroke: None  Toolbar Icon: None 
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If checked, the application will allow the user to view sonar images anywhere 
on the network so long as the sonar is set to Broadcast mode. 
 

Command Keystroke: None  Toolbar Icon: None 
Only 

This flag enables Ethernet frame rate and data acquisition control without data 
retrieval, for use with video output when Ethernet bandwidth or noise limitations 
prevent reliable two-way Ethernet communication with the sonar.  It sends ping 
commands at the current frame rate, with no request for returned data.  Sonar 
control commands such as Gain, Window Start, etc. may be used to change 
data acquisition parameters, but no image files may be saved as no acoustic 
data will be returned. 
 

Sync Sub-Sub-Menu 
 
The Sync modes enable multiple DIDSONs (or 3rd-party equipment) to operate in either 
a Simultaneous or Sequential transmit mode.  For a multiple DIDSON setup, the host 
PCs must have sequential fixed IP addresses (e.g. 128.95.97.200, 128.95.97.201, 
128.95.97.202, etc.), with the sync master (Output flag set) using the lowest address.  
The host PCs and associated sonars must not be in broadcast mode. 
 
Input  Keystroke: None  Toolbar Icon: None 
 

Wait for a COMM_SYNC message from another DIDSON (or 3rd–party) 
application before sending a frame request to the sonar.  Use the Set 
Mode command to choose the type of sync (Simultaneous or 
Sequential) and the Trigger on sequence number N. 
 

Output  Keystroke: None  Toolbar Icon: None 
 

Send a COMM_SYNC message to all sonars (uses broadcast address) 
in Simultaneous mode, or to sonar IP XXX.XXX.XXX.XXX+N  of 
Sequence Length sonars in Sequential mode. 
 

Set Mode Keystroke: None  Toolbar Icon: None 
 

Trigger on  Transmit on the indicated sequence number.    
Output mode sonars always transmit on sequence  
0, while Input mode sonars will transmit on 
sequence 1 to Sequence Length – 1. 

 
Sync Record  Applications synced on input follow the record  

state of the master output application.  In addition, 
the master PC’s frame times are inserted into the 
slave PC’s recorded frame headers. 

 
Simultaneous  All sonars transmit at the same time, with a  

COMM_SYNC message broadcast at the current 
frame rate. 
 

 
Sequential  Sonars transmit in a round-robin format, with a  
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COMM_SYNC message sent to successively 
incremented IP addresses up to Sequence Length 
– 1 at the current frame rate. 
 

Sequence Length The number of sonars to be synced in Sequential  
mode. 

 
Local Sync Only Multiple sonars will be controlled from multiple   

Instances of the DIDSON software on a host PC. 
COMM_SYNC messages are sent to the host 
local IP address on sequential Port numbers in 
Sequential mode, or broadcast in Simultaneous 
mode. 

 

 
 

 
Demo  Keystroke: None  Toolbar Icon: None 

 
If checked, the topside software will allow the user to exercise sonar-related 
controls with no sonar attached. 

 
Sonar Sub-Menu 
 
DIDSONV5.ini  Keystroke: None  Toolbar Icon: None 
File 

Sonars with firmware Rev 5.04 and higher keep the sonar configuration data 
(serial number and {Long Range, 3000m, Split Body, WR Input, WS Extended, 
Big Lens, Aux Lens, Compass} options) in a permanent Config.ini file.  
Subsequent firmware upgrades may be made without the need to reset these 
parameters, and the topside application will display the sonar firmware revision 
number in the View->Header pane under Sonar Status.  Upgrading to sonar 
firmware Rev 5.04 or higher from Rev 4.69 or earlier will require a one-time 
setting of these values via the Edit->Sonar->DidsonV5.ini File dialog. 
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Sonars with firmware Rev 5.04 and higher keep the sonar configuration data 
(serial number and {Long Range, 3000m, Split Body, HR Lens, Compass} 
options) in a permanent Config.ini file.  Subsequent firmware upgrades may be 
made without the need to reset these parameters, and the topside application 
will display the sonar firmware revision number in the View->Header pane 
under Sonar Status.  Upgrading to sonar firmware Rev 5.04 or higher from Rev 
4.69 or earlier will require a one-time setting of these values via the Edit-
>Sonar->DidsonV5.ini File dialog. 
 
Configuration Parameters 
 
Enable Update Check this box to enable changes in sonar configuration. 
Long Range  Sonar is a DIDSON-LR (1.2/.7 MHz operation). 
1000m/3000m  Sonar has a 1000m/3000m depth rating. 
Split Body  Sonar is a Split-Body model 
WS Extended  Sonar has A/D programmed for extended Window Start 
Big Lens  Sonar is mounted with Hi-Resolution (Big) Lens 
Aux Lens  Sonar has Aux Lens mounted on swing arm 
Compass  Sonar has internal compass installed 
WR Input  Sonar has >= Rev 3-8B power supply (9-36Vdc input) 
UHMD v2  Check when using DIDSON-DH with v2 OLED display 
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The DIDSON sonar serial number must be entered here  for correct 
operation for units earlier than SN20.   Mechanical and software differences 
between different DIDSON units necessitate changes in focus and range 
calculations between units.  Check boxes for Long Range and other model 
options should be set appropriately. 
 
This release of the topside application and associated sonar firmware now 
includes the default use of Broadcast mode, which is enabled by checking the 
Broadcast box in the Edit->Sonar->DidsonV5.ini File dialog, and also checking 
Edit->Sonar->Broadcast Commands.  This allows the  topside PC to use the 
standard DHCP address protocol, or to run with a different fixed IP subnet 
address than the sonar.  
 
The topside computer’s IP address must be fixed (e.g. do not use DHCP) if not 
using the Broadcast mode (sonar default).  Use this command to change the 
sonar IP address and subnet mask and copy these parameters and the sonar 
Ethernet port number (must remain 700 for Broadcast mode), sound velocity, 
Ethernet timeout value and sonar serial number to the Didson.ini file on the 
sonar CompactFlash drive, if currently connected to the sonar. 
 
In cases where the PC operates on a matching fixed IP subnet, the Broadcast 
box may still be checked for the sonar, which will allow multiple viewing stations 
on the network (one Master and N Slave applications, see Edit->Mode-
>Master/Slave). 
 
The SSID flag enables the sonar to broadcast its own serial number, IP 
Address, Ethernet Port, and Broadcast status to the network.  Any number of 
sonars with unique IP addresses may be run from one or multiple PCs topside.  
The command Edit->Sonar->Discover Network will display all sonars currently 
powered up on a network with SSID enabled.  The information is broadcast 
while waiting for a topside Ethernet connection after power-up, and every 3 
seconds thereafter.  Leaving this flag set (default) make troubleshooting 
connection issues easier. 
 
The Reconnect flag directs the sonar to test for an Ethernet command once 
every 60 seconds while in Autonomous Mode.  This will result in a “freeze” of 
the image for 1 second per minute while the sonar tests for a topside command.  
Check this flag if you wish to reconnect the sonar after using in Autonomous 
Mode without having to power cycle the unit (unchecked by default). 
 
Updating the sonar network information requires sonar firmware V4.26 or 
higher.  If the sonar network information is different from that present in the 
topside DidsonV5.ini file (or unknown), the application will broadcast a request 
for sonar network information.  If the sonar is powered up and physically 
connected it should return its network information in a broadcast packet.  Then 
either the topside PC may be reconfigured to match the sonar, or the topside 
network settings may be uploaded to the sonar.   Changing the sonar network 
settings will not take effect until after the sonar has been power-cycled. 
 
The Etherdata checkbox should be selected if you desire image data to be 
broadcast via Ethernet while operating in Autonomous mode.  The associated 
Nth Frame parameter sets the rate at which the image is output.  Input a larger 
number to limit Ethernet bandwidth requirements. 
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Select the appropriate Mount option; Lens Up or Lens Down.  Lens Up  refers 
to an orientation where sonar rests above the mounting fixture, secured with 
screws coming up from underneath, while Lens Down  indicates that the sonar 
is being “hung” from the mounting fixture.  An incorrect selection will cause a 
left-right reversal in the acoustic image. 
 
The Extended window options are available for DIDSON sonars with serial 
numbers 19 and higher.  The extended windows use a slightly lower frequency 
clock to control sample rates (Window Length) and delay periods  (Window 
Start), allowing reliable operation at the shortest HF window length (1.25m), 
and extending the other windows to even lengths of 2.5m, 5m, 10m 20m, and 
40m.  The clock setting is saved in the sonar Didson.ini file and also recorded in 
the frame headers.   Extended windows require sonar firmware 4.30 or higher. 
 
The Focus Master (Remote (PC) or Local) setting directs the responsibility for 
sonar focusing (while connected via Ethernet) to the remote controller (e.g. 
topside PC application or embedded CPU), or the sonar itself.  For systems 
using the DIDSON topside software, this should be left in the Remote position.  
Users employing an embedded controller (e.g. an AUV) have the option of 
Local control to relieve the controller of calculating focus position.  Focus 
commands may still be sent via Ethernet to override the Local focusing 
defaults. 
 
Three parameters are available to optimize the automatic focus control:  water 
temperature range, water type (salinity), and focus mode (center beam or 
averaged).  The water temperature range and water type allow the calculation 
of sound velocity, and hence index of refraction, of both the water and the lens 
materials.  The focus mode allows the user a choice between optimizing the 
image in the center of the field-of-view, or for the best focus across the entire 
field-of-view.  It should be noted that at close ranges (< 5m) the depth-of-field 
can become shorter than the window length, and manual focus override is 
available to  sharpen details at the beginning or end of the window (the 
automatic focus is set for the center of the window’s range). 
 
The Status & Control options control the default sonar NTSC video and/or VGA 
output screen when operating in autonomous (no Ethernet connection) mode.  
The Basic mode displays only the acoustic image, range markers, frequency 
mode, and window start/length values, while the Advanced mode adds 
additional status and control parameters.  Advanced mode also allows access 
to the system page when operating in switch control mode (SW1+SW3 
simultaneously). 
 

Load Sonar Keystroke: None  Toolbar Icon: None 
Settings 

Loads all parameters stored in the DidsonV5.ini file from a user-specified file. 
 

Save Sonar Keystroke: None  Toolbar Icon: None 
Settings 

This command saves all parameters stored in the DidsonV5.ini file to a user-
specified file.   This is useful for storing multiple configurations for a single 
sonar, or default configurations for multiple sonars. 
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Command Keystroke: None  Toolbar Icon: None 
Only 

This flag enables Ethernet frame rate and data acquisition control without data 
retrieval, for use with video output when Ethernet bandwidth or noise limitations 
prevent reliable two-way Ethernet communication with the sonar.  It sends ping 
commands at the current frame rate, with no request for returned data.  Sonar 
control commands such as Gain, Window Start, etc. may be used to change 
data acquisition parameters, but no image files may be saved as no acoustic 
data will be returned. 
 

Broadcast Keystroke: None  Toolbar Icon: None 
Commands 

Set this flag to use the IP broadcast address (255.255.255.255) for all Ethernet 
communication with the sonar.  This guarantees that the sonar will receive the 
network information query even if its IP settings are mismatched with the PC 
client.  Check the Broadcast box in the Edit->Sonar->DidsonV5.ini File dialog 
so that the returned data may be displayed on the client PC.   
 
Clear this flag if there is more than one DIDSON on the network; then the 
network commands will be directed to the current sonar IP address only, 
preventing changing parameters on multiple sonars with a single command. 

 
Network Keystroke: None  Toolbar Icon: None 
Discovery 

This command directs the topside application to listen for all sonars currently 
powered on and with SSID enabled (see Edit->Sonar->DidsonV5.ini File).  Any 
sonar in the list may be selected, and the application will shift to communication 
with that sonar.  Selecting a sonar will automatically update the network 
information also found in the DidsonV5.ini File dialog.  Sonars with SSID 
enabled will broadcast their serial number, IP Address, Ethernet Port and 
Broadcast status as seen below: 
 

 
 

Units Sub-Menu 
 

Feet  Keystroke: None  Toolbar Icon: None 
 
Use English units for control & display (feet, feet/sec, deg F). 
 

Yards  Keystroke: None  Toolbar Icon: None 
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Use English units for control & display (yards, feet/sec, deg F). 
 

Meters  Keystroke: None  Toolbar Icon: None 
 
Use Metric units for control & display (meters, meters/sec, deg C). 
 

 
View Menu 

 
Toolbar Sub-Menu 
 
All the toolbars are dockable, which means they may be moved by dragging the toolbar by 
grabbing the raised ridge at the left edge with the left mouse button, and moved to various 
positions within the main application window, where they will remain during main window 
moving and resizing operations.  They may also be dragged to any position over the main 
window or on the desktop. 
 

 
 
Combined Keystroke: None  Toolbar Icon: None 
 

All control buttons from the following three toolbars are displayed.  
 

 
 

FOV-PTR Keystroke: None  Toolbar Icon: None 
 
Controls relating to the wide field of view display modes are displayed. 
 

 
 

Fish   Keystroke: None  Toolbar Icon: None 
Processing 

Controls relating to fish post-processing modes are displayed. 
 

 
 

Image  Keystroke: None  Toolbar Icon: None 
Processing 

Controls relating to basic image processing modes are displayed. 
 

 

 
 

Special Keystroke: None  Toolbar Icon: None 
Processing 

Controls relating to special image processing commands are displayed. 
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Status Bar Keystroke: None  Toolbar Icon: None 

 
Toggles the status bar on and off. The status bar is at the bottom of the 
window. The bar has the following fields: 
 
Left side:  A description of the command selection currently under the mouse 
pointer. 
 
NO SERVER, CONNECTED or DEMO MODE:  Status of Ethernet connection 
between topside computer and underwater unit. Accept a minute or so wait 
after power-up before the connection occurs. DIDSON has to go through a boot 
sequence before it connects the Ethernet.  The connection is inactive in DEMO 
MODE. 
 
PAUSE or RUN (real-time), STILL or MOVIE (playback):  Status of the 
communication link in real-time mode.  Display a single frame or a sequence of 
frames in playback mode. 
 
ONCE or LOOP (playback): Run through the frame sequence once or loops 
until asked to stop. 
 
Total xxx:  The playback file has xxx frames. 
First x:  The first frame in the sequence is x in the file. 
Current y:  The frame imaged is y in the file. 
Last z:   The last frame in the sequence is z in the file. 

Controls Keystroke: None  Toolbar Icon:  
 
Show or hide the Control/Display/File Position pane. 

Header Keystroke: None  Toolbar Icon:  
 
Toggles to display or not display the File Header window. The File Header 
window is the text-filled window on the right side of the display. The File Header 
displays parameters that are given once at the beginning of the file such as 
filename, date, and collection parameters.  When the file is first stored or later 
displayed, the operator has the option to enter a short Header ID string up to 
256 characters long. The file also has a frame header for each frame in the file.  
These data are updated as the new frames are displayed. Platform status 
values must be supplied and merged by the platform software as part of the 
data storage procedure. 
 

Keep on Keystroke: None  Toolbar Icon: None 
Top 

Set this flag to keep the DIDSON application visible when it loses focus (e.g. 
after clicking on another window or application icon). 
 

Palette  Keystroke: None  Toolbar Icon: None 
 
Toggles the display of the current palette, scaled by the current values of 
Intensity and Threshold.  The total width of the window represents 90 dB of 
dynamic range. 
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User Params Keystroke: None  Toolbar Icon: None 

 
Brings up a dialog that displays up to 8 user-defined float  variables stored in 
the DIDSON .ddf frame headers (requires a custom embedded controller).  The 
labels and display precision values may be edited and are stored in the 
DidsonAppV5.ini file.. 

 
Image Menu 

 
Capture Sub-Menu 
 

Record  Keystroke: w  Toolbar Icon:  
 
Data is recorded into files with a default naming convention of yyyy-mm-
dd_#nnn_xF.ddf, where yyyy is the year, mm is the month, dd is the day, nnn  
is a sequence number starting at 000 for any given day, and x is either L (for 
1.1MHz operation) or H (for 1.8MHz operation). 
 
Recording during playback: 
 
When a file is open for playback, pressing the record button marks the start of a 
frame subset, and pressing the record button a second time marks the end of a 
frame subset.  The frame subset is saved to a new file with the string _Snnn 
appended to the default filename, where nnn is a sequence number for snippet 
files taken from the master source file.  For example, suppose the file 2001-11-
06_#023_HF is open for playback.  The record button is pressed at frame 16 
during playback and pressed again at frame 25; the range of frames (inclusive) 
will be saved to the file 2001-11-06_#023_HF_S000.ddf. .  The record button is 
pressed again at frame 35 during playback and again at frame 67; the range of 
frames (inclusive) will be saved to the file 2001-11-06_#023_HF_S001.ddf. 
 
The start and ending frames are recorded into the master header, and the 
source file frame number is displayed below the progress indicator during file 
playback.  The source file frame time is displayed in the Header View window. 
 
If the flag Image->Capture->Record Options->Auto Prompt for Header ID is set, 
then the user will be prompted for new Header ID information before each file 
snippet is saved. 
 
Real-time recording: 
 
If the Total Frames parameter is equal to 0, then recording will continue until 
the control is activated again to disable recording. 
 
If the Total Frames parameter is non-zero, then recording will stop after the 
indicated number of frames have been written to the data file.  If the Image-
>Capture->Record Options->Repeat Total Frames flag is set, then additional 
files of Total Frames length will be generated as long as the record mode is 
active. 
 
Changing parameters such as Window Start or Window Length is allowed 
during (real-time) recording.  However, if the Auto Resolution box is checked, 
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such that changing the data acquisition window forces a change in transmit 
frequency, the current file will be closed and a new file opened using automatic 
filename generation without interrupting the recording process.  This is 
necessary because file playback depends on calculating frame offsets from the 
beginning of a file, and since LF and HF frames have differing lengths, mixing 
frequencies within a given file would generate seek errors. 
 
Note that the sequence numbers of the files representing a single continuous 
recording at changing frequencies will most likely not match, as the numbers 
depend on previously recorded data at each frequency within the current 
working directory. 
 

Record  Keystroke: None  Toolbar Icon: None 
Options 

Autostart Record on Sonar Connection 
When this flag is set recording will start 
automatically 10 seconds after connecting to 
the sonar in whatever mode has been set 
(frames may not be immediately written to 
the image file if conditional parameters such 
as Record over Threshold are enabled). 

 
Lock Controls 
Disables Frame Rate, Frame Total, 
Receiver Gain, Window Start, Window 
Length and Focus during recording when 
set.  The controls are automatically re-
enabled when recording stops. 

 
Continuous Mode 
Toggles Continuous Mode on and off.  If 
Repeat Total Frames is selected, recording 
stops and and a new file is started after 
Total Frames are received. If N Minutes per 
File is selected, then new files are started 
every N minutes, and synchronized to the 
top of the hour. This process continues until 
Continuous Mode or Record is toggled off. 

 
Auto Prompt for Header ID 
When checked, the edit window to write a 
new Header ID string is launched whenever 
a new file is started except in auto repeat 
files mode. 

 
 
 

Time Lapse 
Use this flag to enable time lapse recording.  When set, frames will be saved  
every N seconds (or N frames) regardless of frame rate, where N is a minimum 
of 1 second (or 2 frames) and a maximum of 864,000 seconds (one frame per 
day.  The displayed  frame rate remains controlled by the Sonar Control Frame 
Rate. This control is useful for Time Lapse Acoustography where slow changes 
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such as sediment distribution or crustacean populations are monitored, , or for 
maintaining a high frame rate for user observation while recording a subset of 
the images for post-processing.  Used only for realtime recording. 
 
Periodic:  N Minutes every Hour 
Use this flag to enable periodic recording.  When set, frames will be saved for N 
minutes out of every hour.  If the Time Lapse flag is also set, then time lapse 
recording will be enabled for N minutes out of every hour.  Used only for 
realtime recording.  If Randomize Start is checked, then the start time for each 
record segment will be randomly generated at the top of each hour (the first 
segment always starts at 0 minutes).  If used in conjunction with Continuous 
Mode then a new file will be generated for each segment, assuming that N 
Minutes per File equals N Minutes every Hour. 
 
N Samples Over Threshold  (N Total Within Frame) 
Use this flag to enable periodic, on detection recording.  If the Detect Motion 
command has been invoked, then frames will be saved when N samples of the 
processed image are non-zero (the Threshold parameter controls the 
convolution algorithm, and mirrors the parameter in Processing->Show 
Parameters.   If not, then a processing routine counts all samples greater than 
Threshold and frames are saved when N samples exceed that value.  If the N 
Minutes every Hour  flag is also set, then on detection  recording will be 
enabled for that period only. 
 
N Samples Over Threshold  (N Minimum Cluster Size) 
When this option is selected (only available when Detect Motion has been 
invoked) then frames will be saved when the largest contiguous cluster in the 
current frame matches or exceeds the N Samp parameter (mirrored in the 
Processing->Show Parameters dialog). 
 
N Samples Over Threshold  (Persistence (frames)) 
When on, any frame meeting the minimum threshold and cluster size 
requirements will trigger a contiguous save of N frames (retriggerable within the 
N frame period).  Also available in the Processing Parameters dialog for CSOT 
processing.  This may be useful when background subtraction leaves little or no 
“noise” in the image, when weaker target returns are not consistent, filling in the 
gaps where the threshold and/or cluster size requirements are not met. 
 
Insert Prequel 
Use this flag to insert N (persistence) frames before the trigger (over threshold) 
frame for each threshold event.  This makes the output file larger, but gives a 
more continuous look to the output file.  Used for both real-time Over Threshold 
recording and CSOT processing when Persistence is enabled. 
 
All Every Nth File 
Use this flag to record all frames every Nth file, regardless of threshold or 
cluster size requirements.  Only effective when used in conjunction with 
Continuous Mode recording. 
 
Periodic:  While Fish are Detected 
Use this flag to enable periodic, on detection recording.  The Count Fish 
command must be invoked before this flag takes effect.  Frames will be saved 
whenever the fish counting routine has at least one “potential fish” within the 
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counting window.  If the N Minutes every Hour  flag is also set, then on 
detection  recording will be enabled for N minutes out of every hour.  If this flag 
is set when counting fish in a file during playback mode, then a new .ddf file 
with the identifier FC_ prepended to the filename will be written to disk as the 
file is processed.   
 
Save Displayed Data Only 
Use this flag to save processed data as displayed in the image window, rather 
than the default raw data samples.  This is primarily intended to enable saving 
motion-detected data for subsequent file compression, but may be used to 
store any data as displayed (e.g. background data, transmission loss corrected 
data, etc.) 
 
SequenceStart at # 
A starting filename sequence number may be entered here.  For instance, if 
images are being stored on portable media and each disk holds 80 
(#000…079) files, then entering 80 before starting to record to the second disk 
will preserve the file sequence across disks, to avoid the duplication of file 
sequence numbers which would occur if the second disk started at sequence 
#000.  This value must be updated before each disk change (e.g. 80, 160, 
240…) to provide contiguous, unique filenames.  The default filename algorithm 
uses time (YYYY-MM-DD_HHMMSS) instead of sequence number (_#NNN) 
which guarantees unique filenames. 

 
Timer Keystroke: None  Toolbar Icon: None 
Recording 

Set this flag to enable programmed timer recording, using the information 
previously entered with the Timer Data Entry command.  The timer mode works 
much as a standard VCR, recording files of N minutes with predetermined 
sonar parameters at {Hourly, Daily, Once} intervals. 
 

Timer Data Keystroke: None  Toolbar Icon: None 
Entry 

Allows the user to save (and clear) preprogrammed sonar and time parameters 
for unattended recording.  The programs may be stored in one of three modes:  
Hourly, Daily and Once.  The Hourly mode saves files of a specified duration 
starting at the indicated minute of each hour.  The Daily mode saves files of a 
specified duration once a day starting at the indicated hour and minute.  The 
Once mode does a one-time-only recording at the indicated date and time.  The 
current values of Frame Rate, Receiver Gain, Window Start, Window Length, 
Focus and the LF/HF setting are also saved with the mode and time 
parameters.  The programs may be set up either in Demo Mode or while 
connected to the sonar.  A maximum of 256 programs may be saved. 
 
Setting the Disable transmit when not recording flag allows multiple sonars to 
record during non-overlapping periods without acoustic interference, and also  
may be used to conserve power. 
 
When the Move to pan/tilt position flag is checked, a connected and enabled 
ROS or Sidus pan/tilt unit will be commanded to move to the indicated position 
(entered through either the Pan/Tilt edit boxes or from the Set to current 
position flag) at the beginning of the timer recording period.  Setting the Record 
during move flag starts saving frames immediately upon entering the timer 
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recording period, otherwise recording is held off until the physical pan and/or tilt 
move is complete. 
 

 
 

Take Keystroke: Ctrl+T  Toolbar Icon:  
Snapshot 

Use this command to save the current frame as a single frame .ddf file 
(assuming the following flags are not set) using the current filename set with 
File->Set Save Dir/Name. 
 
If the Export->Save as Jpg flag is set, then the current frame is exported to a 
.jpg file using the current filename.  The currently displayed image is saved as a 
jpg file named {CurrentFile}_Frame_N.jpg.  Only the image visible in the display 
pane will be saved, so if the file header information is currently displayed and 
obscures some of the image, it must first be deselected with the View->Header 
command in order to save the entire image.  If the Measure tool is active, the 
area saved is limited to that bounded by the measure box 
 
If the Export->Save only Image Data flag is set, only the acoustic data array is 
saved to a .dat file using the current filename. 
 
In playback mode the frame number is appended to the base filename.  The 
data is saved as displayed, e.g. if using motion correction then the corrected 
data array is saved to the file. 
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Save Only Keystroke: None  Toolbar Icon: None 
Image Data 

Toggles whether to save file header with snapshot or not.  If only image data 
are saved, then only the 96 by 512 bytes or 48 by 512 bytes are saved in the 
snapshot. This makes it easier to use the data in an analysis program such as 
MATLAB. 
 

Record  Keystroke: None  Toolbar Icon: None 
During Pause 

When set, this flag causes the application to continue retrieving image data and 
recording frames (during normal record operations), but the image display will 
not be updated to allow for inspection of a single frame without interrupting 
recording.  If cleared, then pausing (clicking Still Mode) during recording will 
suspend frame acquisition. 

 
Configure Sub-Menu 
 
Annotate Keystroke: None  Toolbar Icon: None 
Status 

Display status information (Time, Latitude/Longitude, 
Heading, Depth, Altitude, Velocity, Pitch, Roll, 
Compass Heading/Pitch/Roll, Sonar Pan/Tilt/Roll, 
H2O Temp) in the image window, individually 
selectable from a dialog opened by the command.  
The Hide Left Range Nums flag may be set to 
prevent interference between the range numbers and  
the status data overlay on left side of image window. 
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Auto  Keystroke: None  Toolbar Icon: None 
Threshold/ 
Intensity When set, this flag sets the display Threshold and Intensity values to default  

values depending on the currently selected processing options.  Clear this flag 
to maintain fixed values for display Threshold and Intensity regardless of 
processing, opening new files, etc. 
 

Boat Icon Sub-Sub-Menu 
 
Boat Length Keystroke: None  Toolbar Icon: None 
 

Set the icon to represent a boat of 5, 10 or 15 meter length. 
 

Pan Zero Keystroke: None  Toolbar Icon: None 
Direction 

Set the nominal zero pan direction to Aft, Forward, Port or Starboard. 
 

Sonar Mount Keystroke: None  Toolbar Icon: None 
 

Set the nominal sonar mount position to Aft, Forward, Port or Starboard. 
 

Show Boat Keystroke: None  Toolbar Icon: None 
 

Enable the display of the boat icon, which when using the sonar from a 
boat with pan&tilt control, this allows the display of the image window 
size and position in relation to the boat.  The image window icon is 
yellow at zero tilt, and fills in progressively with red when tilting up, 
turning completely red at +30 degrees upward tilt.  The icon turns 
progressively green with downward tilt (fully green at -30 degrees). 

 
Display Time from… Sub-Sub-Menu 
 
PC Clock Keystroke: None  Toolbar Icon: None 
 

Check this flag to display time recorded from the PC clock. 
 

Sonar Clock Keystroke: None  Toolbar Icon: None 
 

Check this flag to display time recorded from the sonar clock in the 
Header pane.  The sonar clock is set to the PC clock time when first 
connected by default (see Sonar->Configure->Set Clock).  The sonar 
clock has resolution to .01 seconds, which is displayed when image 
playback is paused. 
 

GPS Clock Keystroke: None  Toolbar Icon: None 
 

If the ZDA aux input is active (or was when an image file was recorded), 
then setting this flag will display the time and date from the GPS clock. 
 
 
 
 

Horizon Data from… Sub-Sub-Menu 
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Platform… Keystroke: None  Toolbar Icon: None 
 

Artificial horizon displays platform orientation when checked. 
 

Sonar… Keystroke: None  Toolbar Icon: None 
 

Artificial horizon displays sonar orientation when checked. 
 
Load Custom Keystroke: None  Toolbar Icon: None 
Palette 

Select an ASCII file (.dcp) as the default CUSTOM palette.  This ASCII file 
should contain 256 lines of 8-bit RGB values, e.g.: 
 
0 0 0 
2 0 0 
4 1 0 
255 255 255 

 
The filename is saved as the default palette for the CUSTOM entry in the 
palette selection control, and is loaded automatically on each subsequent 
launch of the application. 

 
Platform Location as… Sub-Sub-Menu 
 
Lat/Long Keystroke: None  Toolbar Icon: None 
 

Latitude and longitude information from the frame header are displayed 
in the Platform Status group within the Header pane. 
 

 
X/Y Offset Keystroke: None  Toolbar Icon: None 
 

X and Y Offset information from the frame header are displayed in the 
Platform Status group within the Header pane. 
 
L/L Display Format… Sub-Sub-Sub-Menu 
 
dd.ddddddd Keystroke: None  Toolbar Icon: None 
 

Latitude and longitude information from the frame header 
are displayed as (fractional) degrees. 
 

dd mm.mm Keystroke: None  Toolbar Icon: None 
 

Latitude and longitude information from the frame header 
are displayed as degrees and (fractional) minutes. 

 
Use L/L  Keystroke: None  Toolbar Icon: None 
As X/Y 

Generate relative X/Y location from UTM translation of L/L data.  Set this 
flag to write SonarX and SonarY frame header data drawn from the 
Latitude/Longitude values to enable plotting 3D bathymetry data without 
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full vehicle instrumentation.  It may also be used to navigate within a 
predefined area using a GPS location as the origin. 
 

Reset Frame Keystroke: None  Toolbar Icon: None 
Rate 

Use this flag to reset the playback frame rate to the originally recorded frame 
rate when playing back image files.  Clear this flag for reviewing multiple files at 
a uniform frame rate.  
 
 

Show   Keystroke: None  Toolbar Icon: None 
Horizon 

Display an artificial horizon icon within the image pane showing the attitude and 
heading of the sonar as indicated by the compass data.  
 

Export Sub-Menu 
 
Remove Keystroke: None  Toolbar Icon: None 
Bmp File 

All files exported in jpg format create an intermediate bmp file, which is 
automatically removed by default.  Clear this flag to retain the bmp file for 
higher resolution and color accuracy.  The bmp file is generally much larger (as 
much as 20x) than the jpg output.  

 
Save as Jpg Keystroke: None  Toolbar Icon: None 

 
Set this flag to direct the Capture->Take Snapshot command to export the 
current frame as a .jpg file. 

 
Save as Text Keystroke: None  Toolbar Icon: None 

 
This command saves the displayed image in txt format which may be imported 
into many third-party spreadsheet applications. 
 

White  Keystroke: None  Toolbar Icon: None 
Background 

When set this flag remaps the background to white for the Save Frame as 
{Type} commands. 
 

Index Sub-Menu 
 
Clear All Keystroke: None  Toolbar Icon: None 
 

Clear all index marks in the current playback file.  If the playback file contains 
audio notes, you must reaffirm your choice to delete all audio note index marks 
and associated files.  Otherwise, just the frame index marks will be removed. 
 

Next Mark Keystroke: None  Toolbar Icon:  
 

Advance frame counter to the next index mark (frame or audio) in the current 
playback file.  See Stop on Index Mark for additional behavior.  
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In Echogram mode, the next marked fish is selected as indicated by a green 
circle on the display.  This is particularly useful for long files with few detected 
fish, where it would otherwise be necessary to page through many screens of  
blank data to find the next fish.  If viewing the source image in Echogram mode, 
the image loop advances to the next marked fish. 

 

Previous Keystroke: None  Toolbar Icon:  
Mark 

Set frame counter to the previous index mark (frame or audio) in the current 
playback file.  See Stop on Index Mark for additional behavior.  
 
In Echogram mode, the previous marked fish is selected as indicated by a 
green circle on the display. This is particularly useful for long files with few 
detected fish, where it would otherwise be necessary to page through many 
screens of  blank data to find the last fish.   If viewing the source image in 
Echogram mode, the image loop rewinds to the previous marked fish. 

Toggle  Keystroke: None  Toolbar Icon:  
Mark 

Toggle index mark at the current position in the current playback file. If the 
Activate Audio Recording flag is set, you will be asked if you’d like to insert an 
existing audio file at the current position.  This file must be of the same audio 
type (.mp3, .wav, .wma, etc.) as that selected in the Aux->Setup Audio dialog. 
 

Auto Index  Keystroke: None  Toolbar Icon: None 
Marks 

For real-time recording, setting this flag will insert index marks whenever 
succeeding frame times differ by more than 1 second.  This allows easy 
marking of subsections formed within image files from Periodic Record, etc. 
 
For playback, set this flag to automatically insert index marks into the source 
file at each frame marked by CSOT, echogram, or mark fish processing.  Any 
existing index marks are cleared before recalculating the echogram, or when 
importing an echogram count file.   
 

Stop on Keystroke: None  Toolbar Icon: None 
Index Mark 

Automatically pause at each index mark (frame or audio) during playback.  If 
this flag is cleared and the index mark is also an audio mark, then clicking on 
Next Mark will advance to the next audio mark, play the audio note, and also 
play the image  file in the forward direction.  The Previous Mark command will 
move the frame index to the previous audio mark and play the audio note, but 
image playback will be paused. 

 
Playback Sub-Menu 

 

Rewind Keystroke: Home  Toolbar Icon:  
To Start 
 Sets the frame number to zero (or to the start-point set with the Set Endpoints 

command). It is active in Playback only. 
 

Play Reverse Keystroke: �  Toolbar Icon:  
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Plays the currently open movie file in reverse direction. If in Still Mode, it 
displays the previous frame.  If viewing snapshots, it will display the previous 
snapshot.  It is active in Playback only. 
 

Play Forward Keystroke: �  Toolbar Icon:  
 
Plays the currently open movie file in forward direction. If in Still Mode, it 
displays the next frame.  If viewing snapshots, it will display the next snapshot.  
It is active in Playback only.  
 

Fast Forward Keystroke: End  Toolbar Icon:  
To End 

Sets frame number to the last frame in the file (or to the endpoint set with the 
Set Endpoints command). It is active in Playback only. 
 

Still Mode Keystroke: [Space, p ] Toolbar Icon:  
 
Toggles between still mode (single frame advance) and movie mode 
(continuous play) in playback mode. Release the “Pause” button to restart the 
movie. You may also have to click the direction arrows (� or ⊳) to start the 
movie. In real-time mode, it suspends new frame requests to the sonar, pausing 
recording (if enabled) and leaving the last received frame displayed until 
toggled back to RUN. You will see “Pause” on the bottom right of the screen.   
Space  only enabled for playback; use ‘p ’ to pause during record.  
 

Go to Frame Keystroke: None  Toolbar Icon: None 
 
User sets requested frame number in currently open playback file. It is active in 
Playback only. 
 

Set Endpoints Keystroke: None  Toolbar Icon: None 
 
User sets desired start and end frame numbers for currently open playback file.  
Use this command to limit display range or to truncate a file with a File->Save 
or File->Save As command.  Check the Loop on Still for +/- box to automatically 
loop over N Frames when “paused” during playback while the CTRL key is held 
down, or to change the default 2s loop time in Echogram Source View mode.  
The SPACE bar mirrors the Image->Still Mode command toggle.  Active in 
Playback only. 
 

Loop Keystroke: None  Toolbar Icon:  
 
Toggle loop mode on and off.  Loop mode continuously plays the movie when 
on. Otherwise, the movie plays once and stops at the last frame. 
 
 
 
 

Random Clip Keystroke: None  Toolbar Icon:  
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Play a 1 second clip in the current file centered on a random frame number.  
Sets Loop mode and Play Forward automatically.  Open a text file 
RandomFrames_filename.txt (if not already open) and write the random frame 
number to the file, one per line.  A new text file is opened for each new 
playback file. 
 

Rotate Display Sub-Menu 
 
0 Deg  Keystroke: None  Toolbar Icon: None 

 
Set display orientation so increasing range runs from bottom to top in the image 
window.  The Measure tool will work accurately for any window size. 
 

90 Deg  Keystroke: None  Toolbar Icon: None 
 
Set display orientation so increasing range runs from left to right in the image 
window.  The Measure tool will work accurately for any window size or 
orientation. 
 
 

180 Deg Keystroke: None  Toolbar Icon: None 
 
Set display orientation so increasing range runs from top to bottom in the image 
window.  The Measure tool will work accurately for any window size or 
orientation. 
 

270 Deg Keystroke: None  Toolbar Icon: None 
 
Set display orientation so increasing range runs from right to left in the image 
window.  The Measure tool will work accurately for any window size or 
orientation. 
 

Wide FOV Keystroke: None  Toolbar Icon: None 
 

Bring up the Wide FOV control dialog.  This allows the DIDSON to act as a 
combination forward-looking and sector scan sonar, with user control over 
many parameters: 
 

 
 
Total FOV 
The total FOV sets the overall angular width of the expanded sonar image. 
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15 Degrees Set total display FOV to 15 degrees (Hi-Res lens default FOV). 
30 Degrees Set total display FOV to 30 degrees (Std lens default FOV). 
60 Degrees Set total display FOV to 60 degrees. 
90 Degrees Set total display FOV to 90 degrees. 
120 Degrees Set total display FOV to 120 degrees. 
 
Active FOV 
The active FOV determines the portion of the sonar’s native FOV that is used 
during pan sweeps as the expanded FOV image is built up.  A smaller value will 
result in a brighter overall expanded image, but limits the real-time FOV. 

 
5 Degrees Set active FOV to 5 degrees. 
10 Degrees Set active FOV to 10 degrees. 
15 Degrees Set active FOV to 15 degrees. 
30 Degrees Set active FOV to 30 degrees. 

 
Scan Mode Mosaic 
Rebuilds the sample�pixel map at an interval of every N degrees, and 
refreshes the sonar image at the same rate.  This results in a faster compilation 
of the expanded image, at the expense of a blockier appearance. 
 
Scan Mode Smooth 
Rebuilds the sample�pixel map every frame while panning, for the smoothest 
appearance during expanded image formation.  Frame rates may be limited by 
the PC speed as this is a computationally intensive operation. 

 
Interval 
When using Mosaic mode, the interval should normally be set to 1 degree less 
than the active FOV, but may be overridden if desired. 
 
4 Degrees Set refresh interval to 4 degrees. 
9 Degrees Set refresh interval to 9 degrees. 
14 Degrees Set refresh interval to 14 degrees. 
29 Degrees Set refresh interval to 29 degrees. 

 
Control Compass 
Control the expanded image mapping via compass output.  Use this option 
when not mechanically panning the sonar.  Noise and nonlinearites in the 
compass output may introduce some distortion in the expanded sonar image. 

 
Control Pan Value  
Control the expanded image mapping via pan motor feedback output.  Use this 
option when mechanically panning the sonar, for the least amount of distortion 
in the expanded sonar image. 

 
Reference Direction 
Use the Current button to set the current heading or pan value to be the 
reference direction (e.g. center the expanded image around this value).  For live 
data, this defines “straight ahead”.  For playback files, this should be set at the 
frame containing the midrange value of pan or heading.  A specified reference 
direction may be entered into the edit box before clicking the Apply button. 
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Clear   
Clear the display outside of the currently active FOV. 

 
Apply   
Use the displayed settings to generate the wide FOV display. 

 
OK  
Save the displayed settings to the DidsonAppV5.ini file and close the dialog. 

 
Rectangular Keystroke: None  Toolbar Icon: None 
Display 

Show image in a rectangular format of N parallel beams.  This display mode will 
distort the field of view, but allows closer inspection of image details at short 
ranges, especially when using a very short window start.  The Measure tool will 
display the beam under the cursor while the left mouse button is depressed. 
 

Zoom Range Sub-Menu 
 
1 meter Keystroke: None  Toolbar Icon: None 
 

Set image window to a 1 meter vertical range on a right-click zoom command.  
 

2 meter Keystroke: None  Toolbar Icon: None 
 

Set image window to a 2 meter vertical range on a right-click zoom command.  
 

3 meter Keystroke: None  Toolbar Icon: None 
 

Set image window to a 3 meter vertical range on a right-click zoom command.  
 

4 meter Keystroke: None  Toolbar Icon: None 
 

Set image window to a 4 meter vertical range on a right-click zoom command.  
 

Zoom Keystroke:  None  Toolbar Icon:  
 

When enabled this mode zooms in within the boundary of a cursor-drawn box, 
using the range extent of the box exactly, and preserving the original aspect 
ratio of the image in the azimuth direction.  A mouse left-click returns to the 
original image from the zoomed image.  The “Measure” range function only 
works for the default application window size (e.g. not maximized), but the width 
and height values will be correct. 

 
Sonar Menu 

 
Mouse Keystroke: None  Toolbar Icon: None 
Extensions 

Enables or disables Mouse Controls (see Section 7.4).  Default is ON. 
 
 

Update Keystroke: None  Toolbar Icon: None 
Firmware 
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Use this command to upload new sonar firmware.  The new sonar firmware will 
overwrite the present control program on the internal CompactFlash card.  The 
new program will not take effect until the sonar has been power-cycled.  This 
command requires sonar firmware V4.26 or higher.   
 
The local sonar Didson.ini file is automatically deleted when downloading new 
firmware to ensure compatibility.  On the first power-up the firmware will use 
default values to generate a new Didson.ini file.  You should use the Edit-
>Sonar->DidsonV5.ini File command to reload your individual serial number, 
model type (standard or long-range) and other parameters immediately after 
the first power-up cycle.  Then use the Sonar->Reset to Topside Parameters 
command to re-sync the sonar with the topside application. 

 
Configure Sub-Menu 
 

Command Protocol Sub-Sub-Menu 
 
Ethernet Keystroke: None  Toolbar Icon: None 
 

Sets the application for Ethernet commands and data transfer. 
 

RS-232C Keystroke: None  Toolbar Icon: None 
 

Sets the application for serial commands and video output only (not 
implemented). 
 

Settings Keystroke: None  Toolbar Icon: None 
 

Allows choice of COM port and baud rate for RS-232C control (not 
implemented). 
 

Ethernet Transfer Mode Sub-Sub-Menu 
 
By Packet Keystroke: None  Toolbar Icon: None 
Request 

Breaks Ethernet data transfer into [1k,2k,4k,8k,12k] packets for multi-
user Ethernet.  Use the 12k setting for Patton media extenders. 
 

By Frame Keystroke: None  Toolbar Icon: None 
Request 

The default Frame mode sends maximum size packets for optimum data 
transmission rate. 
 
The increase in data transfer can be significant when using Frames. 
You can try each case and note the change in displayed frame rate for 
your case. If the topside computer and sonar are the only ones using 
the Ethernet the Frame mode will usually be the fastest. 

 
 
 
 

Burst Mode Keystroke: None  Toolbar Icon: None 
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If the Burst Mode flag is set, a single request for data is sent to the 
sonar, and the sonar then returns the entire frame (LF or HF) broken 
into packets with a variable delay between packet transmissions, whose 
value is entered when setting the flag (1…100, default 10).  This mode 
allows higher frame rates while still maintaining small packet sizes, but 
does not allow for dropped packets to be detected and retransmitted. 
 
Setting the Burst Mode flag with by Packet Request enabled will send  
frame requests at every ping interval regardless of previous reception 
status.  This increases effective frame retrieval over noisy connections. 
 

Gain Mode Sub-Sub-Menu 
 
Manual Keystroke: None  Toolbar Icon: None 
 

Breaks Ethernet data transfer into customary packets for multi-user 
Ethernet. 
 
Auto Sub-Sub-Sub-Menu 
 
Low  Keystroke: None  Toolbar Icon: None 
Threshold 

If Manual flag is cleared, decreases gain until less than 
1% of samples within the center 16 beams are greater 
than 75 dB intensity, or increases gain to maximum if this 
threshold is not exceeded. 

 
Medium Keystroke: None  Toolbar Icon: None 
Threshold 

If Manual flag is cleared, decreases gain until less than 
3% of samples within the center 16 beams are greater 
than 75 dB intensity, or increases gain to maximum if this 
threshold is not exceeded. 
 

High  Keystroke: None  Toolbar Icon: None 
Threshold 

If Manual flag is cleared, decreases gain until less than 
10% of samples within the center 16 beams are greater 
than 75 dB intensity, or increases gain to maximum if this 
threshold is not exceeded. 
 

Compass Keystroke: None  Toolbar Icon: None 
Settings 

Direct the sonar to store heading information as either True North or Magnetic 
or Magnetic North.  Enter the correction Declination (Variation) for True North 
data recording and display. 
 

Compass Keystroke: None  Toolbar Icon: None 
Status 

Retrieve current compass status (including last compass compensation quality 
factor) and display in the image pane for 5 seconds.  This command is 
automatically sent when first connected to the sonar (if the Compass option is 
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checked in the DidsonV5.ini file) to initialize data for the Compass Settings 
dialog. 
 

Compensate Keystroke: None  Toolbar Icon: None 
Compass 

Perform compass compensation to adjust for the local magnetic environment of 
the sonar.  For best results the sonar should be mounted in its deployed 
configuration, and the entire mount/platform/vehicle must be slowly rotated 
through 360 degrees, taking at least one minute, while the compensation 
factors are being measured and computed.  When finished the quality factor of 
the compensation will be displayed in the image pane (a value of less than 300 
indicates an acceptable calculation).  The display will remain until the 
Compensate Compass flag is unchecked to return to frame acquisition.  If the 
command is unchecked before the compensation process is finished, image 
frames will not be returned until the calculations are complete. 
 

Zero Tilt/Roll Keystroke: None  Toolbar Icon: None 
Offsets 

Direct the sonar to use the current sonar attitude as mechanical zero with 
respect to sonar tilt and sonar roll.  The resulting offset correction factors are 
stored in the sonar Config.ini file. 
 

Auto Retract Keystroke: None  Toolbar Icon: None 
 
Retracts lens focus arm on program exit. 
 

Auto Keystroke: None  Toolbar Icon: None 
Resolution 

If checked, the sonar switches automatically between operating frequencies 
(hence changing beam resolution) as a function of max displayed range.  The 
default for Ethernet operation is off (unchecked). 
 

Go Keystroke: None  Toolbar Icon: None 
Autonomous 

Switch sonar to Autonomous mode while ending connection.  If the Etherdata 
checkbox is selected in Edit->Sonar->DidsonV5.ini File, then the application is 
automatically set to Slave mode. 
 

Patch Beam Keystroke: None  Toolbar Icon: None 
 
Allows beam selection for adding/removing sonar image patching, interpolating 
data over inoperative sonar channels. 
 

Reset to Keystroke: None  Toolbar Icon: None 
Topside 
Parameters Loads current topside sonar control parameters into underwater unit. 
 

 
Restore Keystroke: None  Toolbar Icon: None 
Defaults 

Command the sonar to delete its local Didson.ini and Basic.ini files, and rewrite 
them with system default values.  This command is always Broadcast, so it 
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should only be used with a single sonar on the network.  It may help with 
restoring connection due to corrupt .ini files. 
 

Set Clock Keystroke: None  Toolbar Icon: None 
 
Synchronize sonar clock with topside PC clock on first connection. 
 

Transmit  Keystroke: None  Toolbar Icon: None 
Enable 

 If not checked, transmit is turned off. 
 
Files Sub-Menu 
 
HD Record  Keystroke: None  Toolbar Icon: None 
/Download 

Enables control of hard disk recording in sonar autonomous mode.  The sonar 
is set to the desired operating parameters while connected to the client PC.  

Then on the next power-up cycle, 
after timing out with no 
connection, the sonar will record 
data into .ddf files on the local 
hard drive.  After establishing a 
connection on the subsequent 
power-up cycle, the files may be 
downloaded to the client PC 
and/or erased off the sonar hard 
drive.  Use the Edit->Sonar-
>DidsonV5.ini File command to 
set the timeout to the desired 
value after power-up (e.g. 30 
seconds). 

 
Recording mode (disabled, 
continuous or gated), frames per 
file and frame rate may be set 
while connected to the sonar by 
clicking the Apply button.   

 
Continuous mode recording will save files whenever the sonar is powered up 
and taking data.  If power is switched off while recording in Continuous mode, 
the file currently being written will be lost, and the corresponding amount of disk 
space will no longer show as available. 
 
Gated mode recording will save files when a logic HI signal (nominal 5Vdc, 
minimum 3.0Vdc) is present on the HD_Enable pin 6 of the MHDG-16-BCR 
sonar bulkhead connector.  The gate may be applied any time after main power 
is turned on, and should be removed before the main power is switched off, 
which will close the currently recording file with no loss of data.  The standard 
DIDSON cable does not have a conductor for the gate signal, so using this 
function will require a custom cable. 
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Older Sonars (S/N < 20) 
The Gated  mode of operation is incompatible with Thinnet data transmission 
mode (the sonar hard drive replaces the Thinnet converter board).  For gated 
HD recording the Thinnet output line is used as an input where a HI logic level 
(5V) will enable recording. 
 

Format  Keystroke: None  Toolbar Icon: None 
Sonar HD 

Reformat internal sonar hard drive (does not reformat CompactFlash drive C:).  
This can be useful if many large files have been lost due to power failure during 
recording; the Delete command alone will not recover the affected disk space. 
 

Lens Sub-Menu 
 
Aux Lens Up Keystroke: None  Toolbar Icon: None 

 
Raise (and lower) remote auxiliary lens when enabled. 
 

Focus Keystroke: Ctrl+F  Toolbar Icon: None 
 
Force lens to focus at default setting (mid-range) for the current window. 
 

Retract Lens Keystroke: Ctrl+R  Toolbar Icon: None 
 
Move focusing element to rear position and thus minimize the length of the 
shaft open to the environment.  This also allows access to the linkage retention 
screw, which must be extracted before removing the rear endcap. 

 
Test Sub-Menu ( not used in normal operation) 
 
Compute Keystroke: None  Toolbar Icon: None 
Statistics  

Generates a file of received signal statistics (minimum, maximum and average 
of N samples) for each beam and the sonar as a whole.  The measurements 
are calculated as a 10-frame average.  When transmit is disabled, or the sonar 
is out of the water, this provides a convenient method for noise measurements.  
If the measure box is checked, statistics will be computed for the range of 
samples contained within the displayed box.  Target strengths may be 
calculated by drawing the measure box around a feature of interest, and 
checking the maximum levels for the appropriate beams. 
 
Statistics may be run on playback files as well as during real-time data 
acquisition.  The results are written to the file Didson_Statistics_SNsss_n.txt, 
where sss is the sonar serial number and n is a sequence number for a 
particular directory. 
 

Display  Keystroke: None  Toolbar Icon: None 
Debug Info 

Check to display Ethernet timing and reliability information.  The statistics may 
be reset (to allow for frames dropped during program initialization) with the 
Sonar -> Zero Transfer Counts command.  When the Detect Motion processing 
flag is set, the number of convolved samples over threshold (CSOT) will be 
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displayed.  This aids in setting the value of N in the Image->Capture->Record 
Options->Periodic:  Record N Samples over Threshold. 

 
Exit to DOS  Keystroke: None  Toolbar Icon: None 

 
Force the sonar to quit the DIDSON application and return to the DOS prompt.  
For authorized repair personnel only. 
 

Fill Frame  Keystroke: None  Toolbar Icon: None 
Header 

Test flag for inserting simulated data into the sonar frame header.  For 
embedded control software development use only. 
 

Query Test  Keystroke: None  Toolbar Icon: None 
 
This is a test command for Ethernet communication and is not used in normal 
operation. 
 

Record PS  Keystroke: None  Toolbar Icon: None 
Voltage 

Setting this flag opens a file BatteryLIfeTest.txt that records the voltage of a 
DIDSON-DH battery once per minute over time to determine its capacity.  The 
file is closed when the flag is cleared. 
 

Zero Transfer Keystroke: None  Toolbar Icon: None 
Counts 

Zeros the Ethernet timing and reliability information. The timing and reliability 
information is routinely part of the error log and can be displayed by clicking on 
Edit Menu > Display Debug Info.  
 

Video Sub-Menu 
 

Change Keystroke: None  Toolbar Icon: None 
Palette 

This command launches a dialog allowing the selection of palette, range color 
and status color values for sonar video output.  The values are stored  
both in the topside DidsonAppV5.ini file and the sonar Didson.ini file, and so 
changes will persist across sessions and sonar power cycles. 
 
Choose from 10 different color palettes for the sonar NTSC video output.  
Choose 1 of 15 different colors for the range labels and status information.  Set 
independently from the topside display palette. 
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Correct Keystroke: None  Toolbar Icon: None 
For TL 

This works identically to the topside application transmission loss algorithm, but 
may be turned on and off independently.  The sonar algorithm uses the 
temperature range and salinity settings from the Edit->Sonar->DidsonV5.ini File 
parameters. 

 
Resolution Sub-Sub-Menu 

 
SVGA  Keystroke: None  Toolbar Icon: None 
 

Set sonar video output to SVGA 800x600 resolution. 
 

VGA  Keystroke: None  Toolbar Icon: None 
 

Set sonar video output to VGA 640x480 resolution. 
 

Show Keystroke: None  Toolbar Icon: None 
Controls 

If checked, the underwater unit lists the sonar controls on the left side 
 of the video image. This is used when switches control the sonar or to verify 

settings when the primary display is a NTSC video monitor. 
 
Show Data Keystroke: None  Toolbar Icon: None 
 

If checked, the underwater unit processes the data and generates a sector 
display which can be converted to NTSC video and cabled to the surface. If not 
checked, the underwater unit simply collects the returns and sends them by 
Ethernet topside in the form of byte arrays. The reduced computational load 
when not checked slightly increases the frame rate. 
 

Show Grid Keystroke: None  Toolbar Icon: None 
 

When checked, the underwater unit adds a measurement grid to the video 
display. 
 

Show Range Keystroke: None  Toolbar Icon: None 
 

When checked, the underwater unit adds range information to the video 
display. 
 

Show Status Keystroke: None  Toolbar Icon: None 
 

When checked, the underwater unit adds status information to the video 
display. 

 
Smooth Keystroke: None  Toolbar Icon: None 
Image 

Smooths the data displayed in the NTSC video output by generating additional 
virtual beams via interpolation. 

 
 



 

 37

Processing Menu 
 

Batch Mode Keystroke: None  Toolbar Icon: None 
 

Set this flag before invoking the commands described below to apply the 
indicated command to all .ddf files within the current playback folder. 
 
Set before doing a File->Save As->Type .avi command to convert all .ddf files 
in the current playback folder to .avi files.  In this case the Measure Box 
cropping function is ignored. 

 
This flag also directs the processing of all image files in the the current 
playback folder when invoking the Processing->CSOT->Export CSOT Frames 
command. 
 
If this flag is set when running  the Processing->Echogram->View Echogram 
command, all image files contained within the current playback folder will be 
processed as an echogram or clustergram.  The output image will be saved as 
an .ech file, and count files (FC_*) will be saved in both binary (.dat) and text 
(.txt) formats. 
 
Background Subtraction and Detect Motion processing will be automatically 
applied when running echograms or clustergrams in Batch Mode. 
 
The resulting .ech files may be opened with the File->Open (choose File Type 
as .ech) command.  This also loads the original source image file and imports 
the associated FC_* count file for review or editing.  Thus echogram or 
clustergram output may be reviewed without reprocessing the image source 
file. 
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Show  Keystroke: None  Toolbar Icon: None 
Parameters 
 

 
 
CSOT/Cluster/Echogram 
 
Process Angle  Set azimuthal angle for echogram detection beam.  Only  

fish that cross the process angle with acoustic returns 
above minimum motion threshold will be counted. 

 
Min Track Size Mininum [samples*frames] cluster size for counting.  The  

Echogram track represents the acoustic return of each 
fish in the “process angle” beam(s) built up over the 
range of frames where the signal level is above the 
minimum Motion threshold. 

 
Process N Beams Set effective beamwidth for echogram detection.  When  

Detect Motion is enabled, each process angle beam 
output is the OR’d combination of N beams, increasing 
the likelihood of detection, but also possibly 
overestimating the fish size and length.  When Detect 
Motion is not enabled, the process angle beam output is 
either the maximum of N beams at each sample range 
(Max Over Threshold selected), or the average of N 
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beams at each sample range (Avg Over Thresh 
selected). 

 
Avg Over Thresh Average N beams over Min Threshold for each sample  

range. 
 
Max Over Thresh Use maximum within N beams over Min Threshold for  

each sample range. 
 
Min Cluster Area Minimum area of a cluster in cm^2 for frame export. 
 
Max Fish/Frame Set the RAM buffer size for statistics calculations.  For  

low fish passage rates, set this to a lower number if 
needed to conserve memory.  Otherwise, set above the 
highest number of fish expected in a single frame. 

 
Detect Motion 
 
Min Threshold  Minimum threshold for Detect Motion image processing.   

Samples with an acoustic return above this level after 
Background Subtraction will be convolved and their color 
set to red. 

 
Show Statistics When this flag is set the the largest cluster meeting Min  

Cluster Area will be colored green, and all other clusters 
meeting Min Cluster Area are colored cyan.  Clusters 
over Min Threshold but not meeting Min Cluster Area are 
left red.  In addition, the size of the largest cluster in the 
current frame, largest cluster in the history of displayed 
frames, total number of clusters meeting Min Cluster 
Area, and total “biomass” (integrated cluster area) for the 
current frame will be displayed in the image window.  
These numbers are useful in setting the best values for 
Min Threshold and Min Cluster Area, based on the 
desired size of targets for CSOT frame export or Add 
Fish in Frame operations. 

 
Upstream Mot L�R Set the upstream direction of fish motion for counting to 
L�R. 
 
Upstream Mot R�L Set the upstream direction of fish motion for counting to 
R�L. 
 
Subtract Opp Mot Subtract downstream fish from total fish count in count 
file. 
 
Limits 
 
Min Frame  Minimum source file frame number to process. 
 
Max Frame  Maximum source file frame number to process. 
 
Entire File  Set Min Frame and Max Frame to file limits. 
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Min Range  Minimum range to process. 
 
Max Range  Maximum range to process. 
 
All Ranges  Set Min Range and Max Range to window limits. 
 
Min Angle  Minimum angle in degrees (over threshold). 
 
Max Angle  Maximum angle in degrees (over threshold). 
 
All Beams  Set Min Angle and Max Angle to sonar FOV. 
 

 
 
3D    
 
Bathymetry  (modes may be simultaneously selected) 
 
Track on Local Max produce profile by recursively finding the brightest return 

in the current frame, then following the line of brightest 
returns to the left and right until all “sub-profiles” have 
been traced. 
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Track +/-N Samp number of samples to search in each adjacent beam 
when tracing local profile lines, starting at the sample 
range of the previous beam processed. 

 
First Return > Thresh produce profile by zeroing all samples under the current 

Display Threshold in each beam up to the first sample 
over Display Thresold, and then zeroing all succeeding 
sample to the end of the window range. 

 
Maximum Return color the maximum sample red in each beam, and zero 

all other samples. 
 

 
 
Image Transformation 
 
Factor A (0.0 to 1.0) this controls the weight given to the averaged 

data subtracted from displayed image.  A value of 1.0 
stops updates to the averaged data.  The default value is 
0.95. Another way of thinking about these parameters is 
that as A goes to one, the “memory” of the averaged data 
increases and is less affected by current data values. 
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Factor B (1.0 - Factor A) the weight given to the updates to the 
averaged data.  Factor A and Factor B are used by the 
Background Subtraction algorithm. 

 
Factor C (0.0 to 1.0) this controls the weight given to new data 

averaged with the displayed image.  A value of 1.0 stops 
averaging and displays only new data.  The default value 
is 0.65. 

 
Factor D (1.0 - Factor C) the weight given to the updates to the 

foreground smoothed data. .  Factor C and Factor D are 
used by the Foreground Smoothing algorithm. 

 
Convolve Beams The number of beams used in the convolution algorithm 

of the Detect Motion routine.  The default value is 4, and 
legal values range from 2 to 16. 

 
Convolve Samples The number of samples used in the convolution algorithm 

of the Detect Motion routine  The default value is 4, and 
legal values range from 2 to 16. 

 
Transmission Loss 
 
N   Enter N for N*logR spreading factor. 
 
Man   Enter a non-zero number to manually replace the  

calculated value of the absorption factor alpha. 
 
A (Auto)  Shows calculated absorption factor alpha. 
 
Normalize to 0 dB TL at Start Range 
   Increase software gain at far range. 
 
Normalize to 0 dB TL at End Range 
   Decrease software gain at near range. 
 
Normalize to 0 dB TL Start at Range R 
   Increase software gain at far range relative to R. 
 
Normalize to 0 dB TL at End at Range R 
   Decrease software gain at near range relative to R. 
 
R   TL normalization range in current units. 
 
File Creation Parameters 
 
Auto Count Name Automatically generate names for fish count files. 
 
Binary Countfile Save count data in binary format for PC processing  

or later editing in Echogram mode. 
 
New Countfile on Start a new countfile automatically whenever a new 
Open   .ddf file is opened (default).  When this flag is cleared 
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all fish counts will be appended to the currently open 
countfile, with annotation describing the source file for a 
particular fish. 

 
Biomass File  Save biomass statistics on all frames exported during  

CSOT to a text file.  This is meant to estimate the total 
number of fish when the fish density is sometimes too 
great to resolve individual fish within each frame.  Frames 
that contain defineable individual fish are processed to 
form an average fish cluster area, and average number of 
frames for each fish tracked.  Then the total accumulated 
cluster area for the file is divided by [average fish cluster 
* average fish frame count] to form an estimate of the 
total number of fish in the file.  (Under development) 
 

Echogram File  Save the echogram image output as an .ech file which 
may be reopened for later review or editing without 
recalculating the echogram.  Enabling this option also 
automatically sets the Binary Countfile option, so existing 
echogram counts may be reloaded along with the 
echogram image using File->Open (files of type .ech). 

 
Delete Empty Files When this option is checked, .ech files with no valid 

tracks are not saved. 
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Crosstalk Reduction Factors 
 
Threshold  Minimum value of acoustic return to assume to be 
generating  

crosstalk. 
 
Suppression  When Reduce by Suppression Level is selected, all 
samples  

considered to be crosstalk are reduced by this amount. 
 
Set to Disp Thresh All samples considered to be crosstalk are set to the 
current  

display threshold. 
 
Reduce by S Level Crosstalk reduction factor in dB. 
 
Modify Local Avg Crosstalk samples are set to the average value of the  

three preceeding neighbor values minus the suppression 
level.  This attempts to preserve the level of the 
surrounding background to avoid a “holey” appearance in 
the image. 

 
Beam Pattern Correction 
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Threshold (dB) Minimum value of sample for applying correction factor.  

This keeps noise below the threshold value from being 
increased above the threshold value. 

 
Max Correction (dB) The correction curve is set to 0 dB at the center beams, 
and  

maximizes at this level at the outer edges of the image. 
 
Set to Disp Thresh Automatically set the correction threshold to the current  

dsplay threshold. 
 

Load  Keystroke: None  Toolbar Icon: None 
Parameter File 

Replaces current processing parameters from a custom file filename.prm.  The 
custom file may have parameters tuned for a particular location for real-time 
processing, or even a particular file for post processing. 

 
Save  Keystroke: None  Toolbar Icon: None 
Parameter File 

Saves the current processing parameters to a custom file filename.prm.  The 
processing parameters may be tuned for a particular location for real-time 
processing, or even a particular file for post processing.  Then future processing 
is done more easily by using the Load Parameter File command. 
 

3D Sub-Menu (functions require software license from ScienceGL) 
 

Open Plot  Keystroke: None  Toolbar Icon:  
Window 

Start the 3D rendering application from ScienceGL.  The application renders 
DIDSON image data taken with the 1 degree concentrator lens into 3D images.  
Data may be rendered in real-time or from .ddf source files.  The 3D image is 
static, and requires either a fixed or very stable mount for the sonar, or sonar 
location and orientation information written into the frame headers, such as 
when integrated within an HAUV or ROV platform.  Basic sonar configuration 
and orientation information may be entered or overridden in the 3D->Show 
Parameters dialog, and an assumed velocity may be set for bathymetry or other 
“3D strip” applications where X position data is not present in the frame 
headers. 
 
If rendered from a .ddf source file, the 3D image may be recalculated for the 
best resolution, edited, output as a .jpg or .avi file, etc.  The 3D rendering 
application may also be used in a stand-alone mode for post-processing 3D 
DIDSON files. 
 
The required software license may be purchased as either a PC-specific  seat 
or a hardware dongle for enabling the application on any PC. 
 
 
 
 

Plot File  Keystroke: None  Toolbar Icon:  
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Start the 3D rendering application (if not already open) and plot the currently 
open .ddf image file as a 3D image.  The .ddf source file must have been 
recorded using the 1 degree concentrator lens. 
 

Plot Real-  Keystroke: None  Toolbar Icon:  
Time Data 

Start the 3D rendering application (if not already open) and plot real-time data 
as a 3D image.  The image data must be taken using the 1 degree concentrator 
lens, in either a rotation sweep (panning the sonar horizontally with a 90 degree 
roll, or vertically with a 0 degree roll) or translation (passing over the volume of 
interest in a linear motion with the lens orientated perpendicular to the direction 
of motion) mode. 
 

Show   Keystroke: None  Toolbar Icon:  
Parameters 

 

 
 
This dialog allows the entry of the sonar position and orientation on a vehicle or 
fixed mount, as well as setting a fixed velocity for bathymetry or other “3D strip” 
applications where X position data is not present in the frame headers.  Setting 
the Manual Override flag directs the application to replace the corresponding 
parameters in the frame headers with this data.  If a non-zero velocity is 
entered, then the Sonar X Position frame header parameter will be overwritten 
with an assumed distance based on velocity, frame number, and frame rate. 
 

Background Sub-Menu 
 

Background  Keystroke: None  Toolbar Icon:  
Subtraction 

Enables background subtraction processing.  When the sonar is operated from 
a fixed or extremely stable mount, background subtraction will remove the static 
portion of the acoustic image, showing only objects that move.  This is useful 
for applications such as counting fish (enabled automatically by the Count Fish 
command) or intruder detection in waterside security. 
 
See the Show Parameters command for a description of processing variables. 
 

Auto Fix  Keystroke: None  Toolbar Icon: None 
Background 
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Runs Background Subtraction on the current playback file over enough “empty” 
(no clusters over Minimum Cluster Size) frames to generate a stable 
background, and then sets the Fixed Background flag. 
 

Auto Fix on  Keystroke: None  Toolbar Icon: None 
File Open 

Set this flag to run Auto Fix Background whenever opening a new file for 
playback, including Batch Mode operations. 
 

Detect Empty  Keystroke: None  Toolbar Icon: None 
Frames 

When Background Subtraction is used in conjunction with the Detect Motion 
command, the background buffer is updated only when frames have no clusters 
exceeding the minimum cluster size set in Processing Parameters.  This allows 
background adaptation without suffering from "shadow blooming", and makes 
the Fixed Background command mostly obsolete.  It slows down processing 
compared to "brute force" (all frames) Background Subtraction, so a Fixed 
Background may still be desired when appropriate for very long files or Batch 
Mode processing. 
 

Fixed  Keystroke: None  Toolbar Icon: None 
Background 

Uses a very slow update factor (Factor A = .999) to effectively freeze the 
background used in the Background Subtraction routine, allowing for only very 
gradual changes.  This is particularly effective in reducing background 
“blooming” from the aftereffects of shadows thrown by objects (e.g. fish) 
passing in front of the sonar.  Used in conjunction with the Save Background 
File and Load Background File commands. 
 

Load   Keystroke: None  Toolbar Icon: None 
Background 
File   This command loads a previously saved background file for use with 

the Fixed Background  command. 
 

Save   Keystroke: None  Toolbar Icon: None 
Background 
File  This command exports the current background data array to a named file  

(Filename.bgd).  The background file should be created from an image file with 
no moving targets during background initialization (50 – 100 frames).  Then the 
file may be later recalled to process image files with moving targets (e.g. fish) 
without “blooming” interfering with Detect Motion processing. 
 

CSOT Sub-Menu 
 

Export CSOT  Keystroke: None  Toolbar Icon:  
Frames 

Use this command to reduce the number of frames to view when looking for 
moving targets against a reasonably static background.  The current playback 
file is processed with Background Subtraction and Detect Motion/Foreground 
Smoothing processing enabled, and all frames containing Min Cluster Size 
convolved samples over Min Threshold in a contiguous cluster are saved to the 
output file CSOT_openfilename, to the folder directed by the File->Save Aux 
File Dir to… command.  The Min Cluster Size and Min Threshold parameters 
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are taken from the Echogram Counter subsection in the Fish Parameters 
dialog.  The Processing Limits parameters also apply. 
 
The Min Cluster Size parameter refers to the maximum number of non-zero 
contiguous samples in a given frame after background subtraction and 
convolution.  Only one cluster must match or exceed this parameter. 
 
Typical values for Min Cluster Size will vary depending on target size and the 
dynamic nature of the background image, but 30 or so would work well for 50 
cm fish against a quiet background.  A good default value for Min Threshold is 6 
dB, same as for Echogram processing. 
 
The Background Subtraction parameter Factor A may work better with a value 
such as .98, rather than the default .95 for images with few moving targets.  
Files with many moving targets may benefit from the Fixed Background 
command. 
 
Exported frames with a time difference greater than 1 second since the last 
exported frame are given an Index Mark if the Auto Index Marks flag is set, and 
the image display updates at each new Index Mark. 
 

Insert Keystroke: None  Toolbar Icon: None 
Prequel 

Check this flag to insert a prequel of N (Persistence value) frames prior to the 
first frame in each sequence of frames meeting cluster minimum threshold and 
size requirements.  This provides additional separation between fish detected 
during the Export CSOT Frames command.  It mirrors the identical option found 
in Image->Capture->Record Options under the Periodic:  Over Threshold 
heading. 

 
PersistenceSub-Sub-Menu 

Off Keystroke: None  Toolbar Icon: None 
2 Frames Keystroke: None  Toolbar Icon: None 
4 Frames Keystroke: None  Toolbar Icon: None 
8 Frames Keystroke: None  Toolbar Icon: None 
12 Frames Keystroke: None  Toolbar Icon: None 
16 Frames Keystroke: None  Toolbar Icon: None 

 
When on, any frame meeting the minimum threshold and cluster size 
requirements will trigger a contiguous save of N frames (retriggerable within the 
N frame period).  Also available in the Record Options dialog for image capture.    
This may be useful when background subtraction leaves little or no “noise” in 
the image, when weaker target returns are not consistent, filling in the gaps 
where the threshold and/or cluster size requirements are not met. 
 

Under Keystroke: None  Toolbar Icon: None 
Threshold 

Setting this flag directs the application to export all frames during CSOT 
processing with a maximum cluster size less than Min Cluster Size to an output 
file prefixed with CSUT_.  This allows checking for unintended "discarded"  
frames of a file processed with normal CSOT processing. 

 
Echogram Sub-Menu 
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Marker Sub-Sub-Menu 

Small Keystroke: None  Toolbar Icon: None 
Medium Keystroke: None  Toolbar Icon: None 
Large Keystroke: None  Toolbar Icon: None 
 
These commands allow the selection of Small, Medium or Large echogram 
marker boxes.  The default is Medium.  Long range counting with very high  fish 
density may require the Small size, and visibility will be enhanced with the 
Large markers on short range image files, where individual fish may take up a 
significant fraction of the image area. 
 
Show Hours Keystroke: None  Toolbar Icon: None 
 
When this flag is set before running an echogram, a vertical indicator line will be 
written into the echogram output at each hour transition. 
 
Show Length Keystroke: None  Toolbar Icon: None 
 
When this flag is set, all marked fish lengths are displayed below the marker, 
otherwise, only the currently selected fish mark length is displayed. 
 
Show Tail Keystroke: None  Toolbar Icon: None 
 
Set this flag to add a “tail” indicating direction of fish travel to the echogram 
marker.  The “tail” pointing up indicates downstream travel, and the “tail” 
pointing down indicates upstream travel.  Clear this flag to hide the “tail” on the 
marker.  Fish of unknown travel direction will never display a “tail”. 
 

Scroll Speed Sub-Sub-Menu 
x1 Keystroke: None  Toolbar Icon: None 
x2 Keystroke: None  Toolbar Icon: None 
x4 Keystroke: None  Toolbar Icon: None 
x8 Keystroke: None  Toolbar Icon: None 
 
Use this parameter to control the scrolling speed of the echogram when using 
Image->Playback->Play Forward and Image->Playback->Play Reverse 
commands.  The echogram will scroll at Frame Rate times the speed factor 
(x1/x2/x4/x8) selected here.  The keyboard playback shortcut controls (cursor 
Up/Down/Left/Right and Space) work as with normal image files.  Up/Down 
control Frame Rate, Left/Right control direction, and Space toggles Still/Movie 
mode. 
 

Split Size Sub-Sub-Menu 
Auto Keystroke: None  Toolbar Icon: None 
200 Frames Keystroke: None  Toolbar Icon: None 
400 Frames Keystroke: None  Toolbar Icon: None 
600 Frames Keystroke: None  Toolbar Icon: None 
 
Use this parameter to control the proportion of echogram view versus source 
image view when using Split Screen echogram mode. 
 

Time Scale Sub-Sub-Menu 
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Fixed Keystroke: None  Toolbar Icon: None 
Sliding Keystroke: None  Toolbar Icon: None 
 
The fixed time scale shows the exact frame times at fixed intervals across the 
echogram.  The sliding time scale shows the frame times at multiples of 15 
seconds (mm:00, mm:15, mm:30, mm:45) that move in one-second jumps as 
the echogram is played. 
 

Auto   Keystroke: None  Toolbar Icon: None 
Export 

This will overwrite the current fish count files with current data after every edit 
(‘f’’ key or Enter button) in echogram mode. This will prevent the loss of edited 
data if the computer or application should crash during an echogram edit 
session. 
 

Calculate  Keystroke: None  Toolbar Icon: None 
Statistics 

Examines image data (requires Detect Motion processing) after marking the 
echogram array, extracting fish length estimates and direction of travel. 
 

Display  Keystroke: None  Toolbar Icon: None 
Range Labels 

Show or hide range labels in echogram mode. 

Display  Keystroke: None  Toolbar Icon:  
Split Screen 

When enabled the application will display both the source image view and 
echogram view in a split (left/right) window.  Measure functions may be applied 
to either view, but Zoom will only apply to the source image view.   
 
A right-click within the echogram view will cause the source view to loop around 
the cursor location similarly to switching to the source view display from the full 
window echogram.  Another right-click will return to the default split view, which 
displays the frame indicated by the cursor position within the echogram view.  
 
If the echogram is put in motion, the source image view displays the frame at 
the cursor position within the echogram view, or the frame at the left side of the 
echogram view if the cursor is not found within the echogram view.  When the 
echogram view is static, the source view will update to reflect the indicated 
frame as the cursor is moved within the echogram view. 
 
All of the editing functions described below in View Echogram will also work in 
Split Screen mode, in either view. 
 

Export   Keystroke: None  Toolbar Icon: None 
Echogram 
Counts  This command exports the internal echogram fish count buffer to the 

named files (Filename.txt and Filename.dat).  The .txt file is designed for 
reports and human readability, while the .dat  file is saved for possible recall 
and modification with the Import Echogram Counts command. 
 

Export   Keystroke: None  Toolbar Icon: None 
Echogram 
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as Jpg   This command exports the internal echogram fish count buffer to the 
default file EG_Filename.jpg.  The entire echogram is exported without 
annotation, except for fish markers when the Detect Motion switch is set. 
 

Import   Keystroke: None  Toolbar Icon: None 
Echogram 
Counts  Previously exported echogram count files (Filename.dat) may be recalled 

for review, updated using the echogram marking/clearing tools, and saved to 
the same (or a different) file.  Importing a count file will immediately clear any 
existing count data for the currently displayed echogram. 
 

Use Cluster  Keystroke: None  Toolbar Icon: None 
Data 

Setting this flag overrides the normal “detect within N beams” echogram 
processing, and replaces it (for each frame) with the maximum output for each 
range bin of all samples exceeding the Min Threshold (RED) and belonging to 
clusters meeting the minimum Cluster Area requirement (CYAN).  The resulting 
echogram clusters (tracks) meeting the minimum Track Size and both previous 
criteria are colored GREEN. 
 
This option is most useful for “rare event” files where fish may not cross the 
standard echogram detect beam(s) while meeting the Min Threshold criterion.   

 

View   Keystroke: None  Toolbar Icon:  
Echogram 

The Echogram mode provides a view of N (1…5) averaged beams in the center 
of the sonar image versus time.  It is enabled for playback only.  The echogram 
image may be modified with the standard processing options Background 
Subtraction and Detect Motion.  When the Detect Motion  mode is selected, fish 
detected above the Minimum Threshold value as entered in the Processing-
>Show Parameters dialog will be automatically counted as controlled by the 
Cluster Size parameter in the aforementioned dialog, which also allows 
selection of the Average Over N Beams parameter. 
 
Counts and the echogram display buffer are cleared upon loading a new file, or 
changing the processing options or parameter values for the currently open 
image file.  The entire file is processed, and pages of 800 frames are available 
for display.  When in echogram mode the large left and right arrow toolbar 
buttons (File->Next and File->Previous) change function from stepping through 
image files in the current playback folder to stepping through pages in the 
current echogram buffer, 800 frames per page. 
 
The standard image playback controls (e.g. File Position, Play Forward, Play 
Reverse, Rewind, FF, etc.)  serve to control scrolling the viewable (800 frame 
maximum) portion of the echogram. 
 
Mouse functions are overridden when in echogram mode.  A left-click will mark 
a fish location and add its frame number and range to an internal data buffer, 
resulting in the overlay of a white-framed circle on the display whose size may 
be selected with the Processing->Echogram->Echogram Marker Size 
command.  A left-click within an existing marker box or circle will clear the mark 
and the entry in the internal count array.   
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The Shift and Ctrl keys modify mouse left-clicks in echogram mode.  The 
modifier key must be pressed and released before entering the mouse click.  A 
Shift-left-click will force a marked target to the upstream direction (yellow, with 
“tail” pointing down), while a Ctrl-left-click changes the direction of travel to 
downstream (blue, with “tail” pointing up).  Pressing the Ctrl key before drawing 
a box (with Measure off) around a group of marked fish with delete all marks 
within the box.   
 
Marked fish may be manually edited in echogram mode while viewing the 
source images.  Press Shift, then click anywhere to indicate upstream (yellow, 
with “tail” pointing down).  Press Ctrl, then click anywhere for downstream 
(blue, with “tail” pointing up).  Click along a fish (with Measure off) from head to 
tail to edit the length of the current mark.  Double-click or press ‘f’ on the 
keyboard to end the measurement and enter the new fish length.  As with 
manual fish sizing, the command ‘u’ will undo the fish length measurement one 
segment at a time, or use the command ‘d’ to delete all segments.  
 
You may also draw a line along a fish (with Measure off) from head to tail to edit 
the length of the current mark.  Press Esc, then click anywhere to remove 
current mark.  Draw a line along a fish (with Measure off) to enter a manually 
sized mark at the current frame.  Press Shift or Ctrl before or after to indicate 
direction.  Measure must be off. 
 
When using Detect Motion, the ‘f’ keyboard command will replace the current 
fish length with the current frame cluster length.  Use this technique to manually 
select the best frame of automatically measured fish lengths. 
 
A mouse right-click will return the view to the original DIDSON image file, which 
will loop for +/- 1 second about the selected echogram frame.  The range at 
selection will be indicated on the image display by a green box around the 
center detection beam.  This allows the examination of small targets which may 
be fish just entering or leaving the vertical field-of-view.  Should this prove to be 
true, the location may be marked with a mouse left-click after returning to the 
echogram view from the image view, by right-clicking anywhere within the 
image window.  Drawing a box with the left mouse button (Measure off, and no 
CTRL modifier) will switch to the image view over the range of frames 
contained within the drawn box. 
 
After most of the fish have been processed and counted in the Detect Motion 
mode, small clusters may be marked manually after studying the corresponding 
image frames as detailed above, and the counts and fish frame/range locations 
will be appended to the auto-count data.  Similarly, very large clusters are 
probably two or more fish overlapping within the field-of-view, which may be 
confirmed with the image mode display.  Then the original auto-count mark may 
be cleared by left-clicking within the yellow box, and the actual two (or more) 
fish marked and stored by left-clicking the appropriate locations in the 
echogram view. 
 
If the Insert Index Marks flag is set, index marks are written and cleared into the 
image file frame headers as fish are counted or manually marked and/or edited.  
See the Image->Index sub-menu for additional details. 
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See also the entries for Import Echogram Counts and Export Echogram Counts 
below. 
 

View   Keystroke: None  Toolbar Icon:  
Histogram 

This command provides a histogram view of fish length distribution contained 
within the currently calculated Echogram.  It offers auto or fixed scaling, and 
variable length bin sizes.  It may be updated after manual editing of fish lengths 
within the current Echogram.   
 
There is no print function, but screen capture utilities may be used to save the 
displayed information. 
 

Fish Sub-Menu 
 

Audio Cues Sub-Sub-Menu 
 

Fish Counted  Keystroke: None  Toolbar Icon: None 
 
Enables audio cues during Count Fish processing.  When a valid fish is 
counted, the system will play the audio file FishCount.wav located in the default 
working directory (e.g. {Drive:}\Didson Data).  You may customize the sound by 
renaming any audio file to FishCount.wav and overwriting the default file. 
 
Fish Detected  Keystroke: None  Toolbar Icon: None 
 
Enables audio cues during Count Fish processing.  When a valid fish is 
registered, the system will play the audio file FishDetect.wav located in the 
default working directory (e.g. {Drive:}\Didson Data).  You may customize the 
sound by renaming any audio file to FishDetect.wav and overwriting the default 
file. 
 
Periodic Record Keystroke: None  Toolbar Icon: None 
 
Enables audio cues during periodic recording.  On each instance of recording 
startup, the system will play the audio file PeriodicRecord.wav located in the 
default working directory (e.g. {Drive:}\Didson Data).  You may customize the 
sound by renaming any audio file to  PeriodicRecord.wav and overwriting the 
default file. 

 

Add Fish  Keystroke: None  Toolbar Icon:  
in Frame 

When Background Subtraction and Detect Motion are enabled, this command 
creates a fish count file and automatically measures and adds all fish in the 
current frame to the count file.  It does not calculate direction, but does process 
several frames around the current frame for each fish to determine its best 
length measurement. 
 

Mark Fish  Keystroke: None  Toolbar Icon:  
 
Enables manual counting of fish in playback files.  A dialog box will appear 
showing the fish number, range, length and thickness (see below).  Also, the 
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Zoom  mode is automatically invoked.  Right-clicking a fish will expand the 
image for an automatic range window of Image->Zoom Range->1/2/3/4 meters, 
with height/width aspect retained, centered around the clicked location.  
Drawing a zoom box with the right mouse button will zoom into the box area.  A 
subsequent right-click will return to the un-zoomed (full-frame) image. 
 
If the Rapid Entry flag is not set, click on a fish to mark its range and bearing 
(range will show up in the dialog box).  After selecting a fish, use the cursor to 
measure the length of the fish.  Draw (multiple, if desired) line segments, or 
simply click along the length of the fish to mark its length.  Start at the head and 
proceed to the tail to enable determination of Upstream/Downstream motion.  
Double-click the left mouse button to finish, and the length parameter will 
change to a gray background in the dialog box.  Click the Enter button to add 
the fish (with zero thickness) immediately to the count file, or use the cursor to 
draw a single line across the desired width of the fish.  When the left button is 
released the width parameter will change to a gray background.  Click Enter  to 
accept the current parameters and add the fish to the fish count file. 
 
Click Clear to delete the current measurement and select a different fish. 
 
See Rapid Entry for the measurement procedure when this flag is set. 
 
Filled circle icons are added to the display in Still Mode, with yellow indicating 
Upstream fish, cyan showing Downstream fish, and white representing fish of 
indeterminate direction.   Current fish counts are updated immediately in the 
image display.  This allows counting all the fish in a single frame. 
 

 
 

Rapid Entry  Keystroke: None  Toolbar Icon: None 
 

This flag changes the procedure for manually counting and sizing fish.  When 
set, fish may be measured by simply dragging the mouse across the fish from 
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head to tail with the left button depressed (you may also use a series of clicks 
or drags as in the standard manual operation).  If the length path is not 
satisfactory, use the u key  (default, see Edit->Application->Keymap) to erase 
individual segments, or the d key to clear the current fish measurement.  
Pressing the f key will record the current fish size and range into the fish count 
file. 
 
Checking the Show All box enables annotation of each (or all) fish measured 
with entries for Species, Motion, Quality, Repeat Count and a general Comment 
string, with all information written to the count file for every fish added. 
 
There is no Thickness measurement in Rapid Entry mode.  

 
Stop   Keystroke: None  Toolbar Icon: None 
Counting Fish 

This command closes any currently open fish count file, and is normally used 
when finished with a series of Add Fish in Frame commands. 
 

Image Sub-Menu 
 

Correct for  Keystroke: None  Toolbar Icon:  
Beam Pattern 
  Use this command to correct the displayed image for the typical loss of  

sensitivity at the edges of the image.  See the Beam Pattern Correction 
parameters under the Show Parameters command for more details. 
 

Correct for  Keystroke: None  Toolbar Icon:  
Transmission 
Loss  Use this command to correct the displayed image for acoustic transmission 

loss.  The algorithm adds a range-dependent offset to the data based on the 
formula :  TL = 2*alpha*R + N*log10(R) 
 
where alpha is the sound absorption coefficient, N is the spreading factor (20 is 
default) and R is the range in meters.  The offset correction values are 
normalized to 0 dB at the end of the window, to minimize noise “blooming” with 
range. 
 
You must set the appropriate parameters using Edit->Sonar->DidsonV5.ini and 
Show Parameters for the correction to be valid.  These include settings for fresh 
or salt water, approximate water temperature (from 5C to 20C) and the desired 
spreading factor (e.g. 20), and the coefficient of absorption alpha. 
 

Measure  Keystroke: None  Toolbar Icon: None 
Box 
Statistics Use this command to calculate the minimum, average and maximum sample 

values inside the yellow outlined measure box.  For file playback it will also 
calculate the average of these values over the entire file.  You must start 
playback at frame 0 to get accurate results. 

 
Cursor  Keystroke: None  Toolbar Icon: None 
Statistics 
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 Use this command to will show the pixel intensity and (if enabled) transmission 
loss and transmission loss correction values in dB at the current cursor position 
when Measure is enabled.. 

 
Display  Keystroke: None  Toolbar Icon: None 
Background 

Displays the static acoustic image removed with the Background Subtraction 
command.  This averaged image shows more detail than a single frame. 
 

Display  Keystroke: None  Toolbar Icon:  
Raw Data 

Displays the standard acoustic image while continuing to process data in the 
background.  This allows the comparison of raw and processed data without 
interrupting the processing routines.  When this flag is set before calculating an 
Echogram with Detect Motion enabled, an additional image buffer is formed 
which allows switching between a background subtracted Echogram view and 
the motion detected view. 
 

Display  Keystroke: None  Toolbar Icon: None 
Subtracted 
Data  Modifies the Display Raw Data flag when Detect Motion is enabled to display  

subtracted data (background removed) in place of convolved (motion detected) 
data. 
 
 

Filter Options Sub-Sub-Menu 
 

Mask with Detected Clusters 
 
Keystroke: None  Toolbar Icon: None 
 
When Detect Motion and Display Raw Data are enabled, the detected clusters 
are used as a mask for the raw data, e.g. only raw data samples contained 
within the detected clusters are displayed against a black background.  This 
flag is mutually exclusive with Overlay Detected Clusters. 
 
Overlay Detected Clusters 
 
Keystroke: None  Toolbar Icon: None 
 
When Detect Motion and Display Raw Data (or Display Background) are 
enabled, the detected clusters are overlaid on top of  the raw data, to give high 
contrast to moving objects against the displayed background.  This flag is 
mutually exclusive with Mask with Detected Clusters. 

 
 
 
 

Use Cluster Outline 
 
Keystroke: None  Toolbar Icon: None 
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Set this flag to use the cluster outline, instead of a solid cluster, for display 
when the Overlay Detected Clusters flag is enabled. 

 
Reduce Crosstalk 
 
Keystroke: None  Toolbar Icon: None 
 
This processing is meant primarily for the reduction of artifacts in 3D image 
processing, and has mainly aesthetic value for 2D imaging.  It is not 
recommended for fish counting and/or sizing applications.  The processing 
algorithm looks for bright spots in the image, and reduces the brightness of 
samples located at the same range in the beams affected by acoustic crosstalk.  
See the Crosstalk Reduction Factors section under the Show Parameters 
command for more information. 

 
Select Processed Display Sub-Sub-Menu 

 
Background  time-averaged background image 
Convolved  motion-detected cluster image 
Foreground  time-averaged background-subtracted image 
Outline  cluster outline image 
Profile  bathymetry mode image (3D pre-processing) 
Subtracted  raw data minus background data image 
 
Keystroke: None  Toolbar Icon: None 
 
Selecting various image processing options generates corresponding display 
buffers.  Use this command to override the default display buffer selection to 
display a different active display buffer.  The Processing->Image->Display Raw 
Data flag overrides any processed display buffer selection. 
 

Motion Sub-Menu 
 

Detect Keystroke: None  Toolbar Icon:  
Motion 

Enables motion detection processing.  When the sonar is operated from a fixed 
or extremely stable mount, the motion detection routine first invokes 
Background Subtraction to remove the static portion of the acoustic image, and 
then performs foreground smoothing (if enabled), followed by  a convolution on 
the image.  The resulting data are compared to the Minimum Threshold  
processing variable and set to 0 if less than or equal to that value, and 128 
(fixed 1-bit color) if above it. 
 
The resulting image may be further processed by the Count Fish command, 
and/or the Image->Capture->Record Options->Periodic Record on N Samples 
over Threshold flag may be used to only save data containing moving objects 
larger in aggregate than N samples (in this case the Threshold parameter is 
ignored, as the data have already been processed to a binary value using the 
above-mentioned Minimum Threshold parameter). 
 

Foreground  Keystroke: None  Toolbar Icon: None 
Smoothing 
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Works with the Detect Motion  command to further process a background 
subtracted image, removing transient noise (speckle) from the displayed image.  
The default state of this flag is TRUE, but it may be disabled to observe its 
effect on the data. 
 

Platform  Keystroke: None  Toolbar Icon:  
Motion 
Correction Enables image correction due to platform motion.  Because a single 

image frame is made up of 8 (HF) or 4 (LF) consecutive ping cycles, platform 
motion will introduce a skew between individual beams in the displayed image.  
Correcting for forward (or reverse) motion involves sliding each beam in range 
relative to the first received ping in the frame acquisition cycle.   Correcting for 
changes in heading requires remapping beam data in azimuth. 

 
Show PMC  Keystroke: None  Toolbar Icon: None 
Parameters 

Brings up a window that allows viewing and changing current  processing 
parameters for the Platform Motion Correction command. 
 

 
 
Enable Velocity Enables velocity correction. 

 
Manual Override Forces value for velocity correction. 

 
Enable Heading Rate Enables heading rate correction. 

 
Manual Override Forces value for heading rate correction. 

 
Auto Fill In any given frame, sets of beams may have no acoustic 

data due to rotational platform motion.  When checked, 
this option fills in the image with data interpolated from 
neighboring beams. 
 

Velocity  When Manual Override is selected, this value (in 
m/s) will be used for motion correction.  This is most 
useful for post-processing data taken from a moving 
platform with no integrated velocity information. 
 

Velocity Band  When the difference between the current  
processing velocity and the current platform velocity 
exceeds this number (in meters/second), the current 
processing velocity will be reset to the current platform 
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velocity, and the image mapping will be recalculated 
accordingly. 
 

Heading Rate  When Manual Override is selected, this value (in  
m/s) will be used for heading rate correction.  This is 
most useful for post-processing data taken from a moving 
platform with no integrated heading rate information. 

 
Head Rate Band   When the difference between the current 

processing heading rate and the  current platform 
heading rate exceeds this number (in meters/second), 
the current processing heading rate will be reset to the 
current platform heading rate, and the image mapping will 
be recalculated accordingly. 

Special Sub-Menu 
 

Auto Export Keystroke: None  Toolbar Icon: None 
Jpg 

This flag when set writes a .jpg file of the image once per second, along with a 
corresponding .hdr file containing the frame header data in binary format.  The 
files are exported when connected to the sonar or in playback mode, 
independent of the Image->Capture->Record flag. 
 
The file names are in the form yyyy-mm-dd_hhmmss.jpg and yyyy-mm-
dd_hhmmss.hdr for easy access via a reference time.  The time values will 
depend on the Image->Configure->Display Time from… setting (PC, Sonar, or 
GPS).  The file folder location will depend on the File->Set Aux Dir to… flag 
(File Save Dir or Image Open Dir, as desired). 
 

Bathymetry Keystroke: None  Toolbar Icon:  
Mode 

This command enables up to three profiling algorithms in any combination for 
the purpose of generating bathymetry data for 3D rendering.  It also has the 
effect of greatly reducing the number of samples in each frame, so that 
processed image files may be subsequently compressed by factors of 100 or 
better.  See the Bathymetry group on the 3D tab of the Show Parameters dialog 
for more information. 
 

Cursor Keystroke: None  Toolbar Icon:  
Tracking 

The cursor tracking function stores cursor position versus frame number for up 
to 512 tracks, useful for recording and analysis of target motion (e.g. fish).  Dual 
text and binary files that record the track number, frame number, target range 
and bearing, and other parameters may be exported and later imported for 
viewing and/or editing. 
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Each track may be recorded for up to 512 frames, and if the Auto… feature is 
checked, will automatically generate contiguous multi-track segments.  The 
tracks are displayed 2  
 
seconds (2 * frame rate frames) prior to the first frame within a track until 2 
seconds after the last frame of a track.  Tracks may be individually displayed, 
hidden or cleared. 
 
Selecting this command generates a pop-up dialog containing the following 
controls:   
 
Track   Selects active track from N total tracks. 
Interval   Display every Nth track point. 
Max Len  Display a maximum of N points for each track. 
Hide All   Hide all tracks (retains all track information). 
Show   Display (checked) or hide (unchecked) current track. 
All   Display all tracks. 
Auto…   Generate new track on each new mouse left-click. 
Add   Manually start new track. 
Center Window  Reset zoom coordinates for each frame to keep current 
   frame track point in center of window (automatically 
   clears Auto… function). 
Clear   Clear current track from memory. 
Clear All  Clear all tracks from memory. 
Import   Load track memory from previously exported file. 
Export   Save track memory to text and binary files. 
 
Cursor tracking operates in either Auto… or manual mode.  In Auto… mode, 
each mouse left-click starts a new track, and the mouse button is held down as 
the file plays and a desired target is tracked with the cursor.  This will quickly 
generate rough tracks of targets, which may be subsequently edited in manual 
mode.  The Add button will generate a new track in manual mode. 
 
The usual procedure is to record target tracks at the centroid of each target 
(usually a fish); then sub-tracks of nose and tail position may be added to an 
existing track by using Shift-Left and Shift-Right mouse buttons respectively.  
When track files are exported the sub-tracks are converted to target length and 
aspect angle (in the text file; the original position information is retained in the 
binary file).  An aspect angle of zero degrees is defined as a fish swimming 
directly downrange.  Positive angles up to 180 degrees are calculated when the 
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nose is at a more positive bearing with respect to the tail location, and vice 
versa for negative aspect angles. 
 
When frames are not advancing (Pause or Still Mode) the mouse functions 
(assuming Measure is off) are: 
 
Left   Erase current point (centroid, nose and tail) if clicked on 
   Enter/replace current centroid point in blank space 
 
Shift-Left  Enter/replace nose point 
Shift-Right  Enter/replace tail point 
 
While file is playing, the mouse functions (assuming Measure is off) are: 
 
Left   Enter/replace current centroid point 
 
Ctrl-Left   Erase current track point (centroid, nose and tail) 
 
In either case the following functions are active: 
Right (unzoomed) Zoom to 1.25m range window centered on cursor 
Right (unzoomed box) Zoom into subrange defined by box length 
Right (zoomed)  Return to full window range 
Ctrl-Right  Select current track (click on any point in track) 
 
The current track will be automatically cleared when the last point is erased 
using either the single point Left or continuous (Ctrl-Left) functions. 
 
Tracks in memory may be exported to a disk file using the Export button.  The 
file names default to OpenFileName.log and OpenFileName.dat for text and 
binary file types, respectively.  Selecting an existing file will overwrite the file. 
 
Tracks may be imported for viewing or editing using the Import button, which 
will overwrite any track information in memory up to the length of the imported 
file.  The user selects an existing CursorTrackFile.log file, and the 
corresponding CursorTrackFile.dat file is read into the cursor track structure in 
memory.  The encoded source filename is compared against the currently open 
playback file, and an error message is generated if they do not match. 
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Export Frame Headers Sub-Sub-Menu 
 

First Frame Only 
 
Keystroke: None  Toolbar Icon: None 
This flag when set will export header information from the first frame only of 
each file when the Run Batch flag is set before starting the export operation.  
Use this option when the parameter(s) of interest is slowly changing, such as 
water temperature or humidity. 

 
Generate .csv File 

Keystroke: None  Toolbar Icon:  
 
Use this command to export parameters from the .ddf or .aris file frame headers 
to a .csv (comma-separated value) format file that may be opened directly into 
Microsoft Excel or other spreadsheet applications for plotting or otherwise 
analyzing the data.  The subset of parameters exported comprise Date, Time, 
Go Time, Go Delta, Humidity, Focus, Depth, Heading, Pitch, Roll, Latitude, 
Longitude, Rot Pan, Rot Tilt, Rot Roll, Water Temp, CPU Temp, Battery 
Voltage, Main Voltage and Current Focus.  Some parameters are only available 
in .aris files. 
 
If the Batch Mode flag is set before setting this flag, the frame header 
parameters from all files in the current playback folder will be automatically 
exported to a single output .csv file. 
 

 
Geometry  Keystroke: None  Toolbar Icon: None 
Calculator 

Use this command to estimate the optimal geometry for the sonar altitude as a 
function of sonar tilt, or sonar tilt as a function of altitude.  The calculations 
assume the imaged area is level, and determine the best altitude(tilt) or 
tilt(altitude) based on the current settings of Window Start and Window Length.  
Tilt is measured in degrees (positive) down from the horizontal.  Altitude will be 
indicated in meters or feet depending on the current state of the Units flag. 
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Heading Rate  Keystroke: None  Toolbar Icon: None 
Calculator 

 
 
Use this command to calculate beam coverage versus 
heading rate.  If the sonar platform has control over 
heading rate, the images may be optimized for the current 
settings of Window Start and Window Length. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Mark   Keystroke: None  Toolbar Icon:  
Depth Profile 

This command allows the manual processing of an image file generated in a 
vertical lens orientation, such that the bottom return will show up as a line 
running down the length of the image.  When first invoked a reminder dialog will 
appear to prompt for proper the Reverse setting.  Then a Profile Data dialog will 
accept values for lens depth (in inches or cm) and lens tilt (in degrees).  Next 
the user clicks along the bottom image from minimum range to maximum range 
until the bottom profile is marked satisfactorily.  A previously entered mark may 
be removed by clicking on it. 
 
A right-click will process the marked profile and display the data both 
numerically and graphically.  The profile may be saved using the Image-
>Capture->Save Frame as Jpg command.  The user is queried on saving the 
depth data as a comma-delimited text file on exiting the Mark Depth Profile 
mode.  Selecting an existing file will append the current data. 
 

Mark   Keystroke: None  Toolbar Icon:  
Fish Profile 

This command allows the manual marking of fish within an image file generated 
in a vertical lens orientation, such that the bottom return will show up as a line 
running down the length of the image.  When first invoked a reminder dialog will 
appear to prompt for proper the Reverse setting.  Then a Profile Data dialog will 
accept values for lens depth (in inches or cm) and lens tilt (in degrees).  Next 
the user clicks each fish to be recorded into a text file.  A mark whose size is 
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set by Processing->Echogram->Marker->{Small, Medium, Large} will be 
displayed for +/- Frame Rate frames around the marked frame.  A previously 
entered mark may be removed by clicking on it. 
 
A right-click will process the marked vertical fish distribution and display the 
data both numerically and graphically.  Another right-click reverts back to 
normal image display.  The profile plot may be saved using the Image-
>Capture->Save Frame as Jpg command.  On exiting the Mark Fish Profile 
mode, a text file named FishProfile_filename.txt will be written to the current 
aux output folder. 
 
 

 

Mark Targets Keystroke: None  Toolbar Icon:  
 
Opens or creates a target file, and enables target marking (recording).  In 
playback mode, targets are marked within a given frame by first drawing across 
the width of the target with the mouse, and then drawing down the length of the 
target shadow.  The estimated target width and height will be displayed in the 
Mark Target dialog.  Clicking the Record button will write the target information 
to the file.  Up to 16 targets may be marked in any given frame, and mistakes 
may be erased by using the Clear button (clears only those targets marked in 
the current frame, one at a time).  Changing the current frame will clear the 
target markings. 
 
In real-time mode, targets are marked with a single mouse click at the range 
and bearing desired.  Then the target type, confidence and annotation 
information may be entered before clicking the Record button. 
 
In either mode, clicking Record will also automatically export a .jpg of the 
current frame with the filename in the form  
TGT_CurrentFile_FrameN_TargetN_Type_ConN. 
 
 

Modify Frame Headers Sub-Sub-Menu 
 

Copy PC Clock->Sonar Clock 
 
Keystroke: None  Toolbar Icon: None 
This flag when set allows files with missing or corrupted sonar clock data to be 
rewritten with values from the PC clock parameter.  Use "File->Save" or "File-
>Save As" to rewrite the clock information to the same or new file, 
respectively. 

 
If the Batch Mode flag is set before setting this flag, all files in the current 
playback folder will be automatically corrected to new filenames with the 
addition of a _Fix suffix. 
 
Fix 4-Beam Offset 
 
Keystroke: None  Toolbar Icon: None 
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Use this command to correct image files recorded with software version 
V5.18.xx which incorrectly wrote the image data 4 bytes early relative to the 
start of each frame.  First set this flag, then use the File->Save As command to 
rewrite the image file to a new filename.  Verify the image beam mapping 
correction, and then delete the original .ddf image file. 
 
If the Batch Mode flag is set before setting this flag, all files in the current 
playback folder will be automatically corrected to new filenames with the 
addition of a _Fix suffix. 
 
Force Mixed Format Sub-Sub-Sub-Menu 
 
Type 1/2/3 
 
This enables forced adjustment of data alignment in .ddf files recorded with 
mismatched topside software and sonar firmware.  Normally this should be 
detected and corrected automatically, but some combinations may not be 
handled automatically.  If setting one of these flags allows an image file to be 
played normally, then the File->Save As command may be employed to rewrite 
the file in a "pure" DDF_03 or DDF_04 file format. 
 
Interpolate Lat/Long Data 
 
When this flag is set during file playback, the latitude and longitude data 
recorded in the frame headers N seconds apart (see next entry) is used to 
calculate interpolated position data so that each frame will contain a unique 
latitude/longitude position, effectively increasing the GPS output rate. 
 
 
Interpolation Period Sub-Sub-Sub-Menu 
 
1/2/5/10 Seconds 
 
Sets the period between GPS interpolation endpoints.  A larger value will 
ensure smoother motion between frames, but may not be as accurate if the 
sonar velocity is not constant. 
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Plot Beam Keystroke: None  Toolbar Icon: None 
Patterns 

This command processes calibration .ddf files recorded at Sound Metrics for 
validating the performance of acoustic lenses.  A reference target is suspended 
in a fixed location in the water column, and the sonar is rotated while recording 
data such that the target image sweeps across the entire field-of-view, 
recording the angular orientation of the sonar into each frame header.  When 
the file has been opened for playback, executing this command processes the 
image data for plotting in three views:  Envelope, Beam Patterns, and Beam 
Widths.  Scaling controls and measurement cursors are available to examine 
the pattern data in detail. 
 

 
 
Beam   Select single beam number (All Beams unchecked) 
Range   Data for each beam are plotted +/- Range/2 degrees 
Min dB   Minimum value for Y axis scaling in dB 
Max dB  Maximum value for Y axis scaling in dB 
Min Dg   Minimum value for X axis scaling in degrees 
Max Dg  Maximum value for X axis scaling in degrees 
Beam Envelope Plot maximum intensity of beam versus angle 
Beam Patterns Plot intensity of [One/All] beams versus angle 
Beam Widths  Plot 2-way beamwidths at the -3, -6 and -20 dB levels 
X Cursors  Enable X Cursors with position readouts/controls 
Y Cursors  Enable Y Cursors with position readouts/controls 
X10   Multiple cursor movement increment by 10 
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Beam Pattern Plot of All Beams 
 
Track Target Keystroke: None  Toolbar Icon: None 

 
After automatically enabling Foreground Smoothing and Detect Motion 
processing and setting a minimum cluster size and minimum threshold in 
"Processing->Show Parameters", playing back the file will acquire and track a 
single target (assumes no other targets in the image), and write the range and 
bearing to the target (also target present) in the frame header.  Use "File-
>Save" or "File->Save As" to retain the new header information. 

 
Aux Menu 

 

Audio Record Keystroke: None  Toolbar Icon:  
 
Use this command start and stop manual audio recording.  If recording in Voice 
Activated mode, the audio file will be opened immediately, but actual recording 
will not commence until the input exceeds the previously calculated threshold 
volume (see Audio Setup below). 
 

Audio Setup Keystroke: None  Toolbar Icon: None 
 
Use this command to launch the Audio Setup dialog. 
 
The Sound Card parameter allows the selection of any installed audio device. 
 
The Input From parameter selects the audio source for recording. 
 
Choose the audio file type with the File Format parameter, such as .mp3, .wav, 
.wma, etc. 
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The Audio Quality list shows the available recording modes for the selected file 
format. 
 
Check the Record Voice Annotation box to enable audio note recording into the 
current (real-time or playback) file. 
 
Select the recording mode from Manual (toggle on/off with Aux->Audio Record 
command), Voice Activated (starts on input over threshold as defined by the 
Compute Background Level function; stops on N seconds of silence), or Always  
(record audio continuously whenever image frames are being recorded). 
 
The two sliders enable control over Record Level and Playback Level.  If using 
the Voice Activated mode, always click on Compute Background Level after 
changing the Record Level value.  The Left Output and Right Output meters 
monitor the input levels during computation of background levels and test file 
recording.  Use the Record, Stop, and Play buttons to record a test file using 
the current settings, to check for the appropriate trade-off between audio quality 
and file size. 
 
 
 
 

Mute Audio Keystroke: None  Toolbar Icon:  
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Playback 
Use this command to prevent the playback of audio notes when index marks 
are encountered in the frame headers.  Any currently playing audio note will 
stop when this flag is set. 

 
Rotator Keystroke: None  Toolbar Icon: None 
Control 

This dialog allows control of a Sound Metrics X2, Remote Ocean Systems PT-
10/PT-25 or Sidus Solutions SS250 pan and tilt unit.  For ROS and Sidus 
rotators, the manufacturer and communication parameters are set in the Aux-
>Select dialog.  The SMC X2 rotator has a different dialog interface (see 
below). 
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Factory CCW Limit factory limit for CCW rotation (-180 degrees) 
 
Factory CW Limit factory limit for CW rotation  (+180 degrees) 
 
User Left/Right Limit user set limits, must be between factory settings 
 
User Up/Down Limit user set limits, must be between factory settings 
 
Velocity  ROS: rotation speed in degrees/second [0.5 – 20.0 for 

the PT-10, and 0.5-10.0 for the PT-25] in 0.5 deg steps. 
 
Sidus: rotation speed in degrees/second [0.1 – 20.0] 
 
SMC:  rotation speed in degrees/second [0.0 – 40.0] 

 
Brake   brake force in percent [0=no brake, 100=max brake] 
 
Position  current rotation position in degrees 
 
Go to   enter desired position in degrees 
 
Rev L-R/U-D  reverse sense of rotation to account for sonar mount 
 
Cycle   move between user set limits (loops) 
 
Single Axis  first pan, then tilt for combination moves 
 
Stall Check  monitor position and stop motor if stalled 
 
GO   rotate from current position to desired position 
 
Up Arrow  tilt up while button is pressed 
 
Down Arrow  tilt down while button is pressed 
 
Left Arrow  pan left while button is pressed 
 
Right Arrow  pan right while button is pressed 
 
Apply (STOP)  update settings – limits, speed, brake, etc.  The settings  

may also be updated with Enter  
(stop rotation during GO command) 

 
In addition, the keyboard arrow keys will control Up/Down/Left/Right motion, 
while the space bar invokes the Stop command. 
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 Tripod or Pole mount control dialog 
 
 
Up Arrow  tilt up while button is pressed 
 
Down Arrow  tilt down while button is pressed 
 
Left Arrow  pan left while button is pressed 
 
Right Arrow  pan right while button is pressed 
 
STOP (when red) stop rotation during Go to… or Sweep command 
 
Sweep   moves to left pan limit, then moves to the right pan  
   limit  in increments set by the Active FOV control  
   in the Image->Wide FOV dialog.  The rotator tilts  
   alternately to the up and down limits at each pan  
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   increment to cover a desired volume for 3D rendering.  
   (loops) 
 
Show All  display entire dialog.  This is cleared by default for a  
   simple interface showing just the controls listed above. 
 
Left/Right Limits user set limits, between -180 and 180 degrees 
 
Up/Down Limits user set limits, between 90 and -30 degrees 
   for Tripod mount, and between 30 and -90 degrees 
   for Pole mount  
 
CCW/CW Limits not applicable for Tripod or Pole mounts 
 
Velocity  rotation speed up to 40 degrees/second on any axis 
 
Apply   set user limits and velocity for Go to… moves, including 
   slider drag moves.  Arrow controls will respond  
   immediately to new velocity values with no Apply  
   necessary 
 
Go to   enter desired position in degrees 
 
GO   rotate from current position to desired position 
 
Single Axis  first pan, then tilt for combination moves to limit 
   maximum power draw (including Home command) 
 
Home   return to Pan = 0, Tilt = 0 
 
Set Home  set the current position to Pan = 0, Tilt = 0.  The user  
   limits remain the same, so be careful to observe  
   mechanical rotation constraints and change user limits  
   as necessary to prevent damage to the sonar or  
   rotator. 
 
Reset   clears any motor fault caused by a stall or excessive  
   loading and resets user limits and velocity values  
    
In addition, the keyboard arrow keys will control Up/Down/Left/Right motion, 
while the space bar invokes the Stop command, even when not active (gray). 
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      ROV mount control dialog 
 
 
Up Arrow  tilt up while button is pressed 
 
Down Arrow  tilt down while button is pressed 
 
‘Vertical Sonar’ roll towards lens vertical while button is pressed 
 
‘Horizontal Sonar’  roll towards lens horizontal while button is pressed 
 
STOP (when red) stop rotation during Go to… or Sweep command 
 
Sweep   not applicable for ROV mount orientation  
 
Show All  display entire dialog.  This is cleared by default for a  
   simple interface showing just the controls listed above. 
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Left/Right Limits not applicable for ROV mounts 
 
Up/Down Limits user set limits, between 30 and -90 degrees 
 
CCW/CW Limits not applicable for Tripod or Pole mounts 
 
Velocity  rotation speed up to 40 degrees/second on any axis 
 
Apply   set user limits and velocity for Go to… moves, including 
   slider drag moves.  Arrow controls will respond  
   immediately to new velocity values with no Apply  
   necessary 
 
Go to   enter desired position in degrees 
 
GO   rotate from current position to desired position 
 
Single Axis  first tilt, then roll for combination moves to limit 
   maximum power draw (including Home command) 
 
Home   return to Tilt = 0, Roll = 0 
 
Set Home  set the current position to Tilt = 0, Roll = 0.  The user  
   limits remain the same, so be careful to observe  
   mechanical rotation constraints and change user limits  
   as necessary to prevent damage to the sonar or  
   rotator. 
 
Reset   clears any motor fault caused by a stall or excessive  
   loading and resets user limits and velocity values  
    
In addition, the keyboard arrow keys will control Up/Down/Roll CCW/Roll CW 
motion, while the space bar invokes the Stop command, even when not active 
(gray). 
 

X2 Rotator Sub-Menu 
 
Auto Home Keystroke: None  Toolbar Icon: None 

 
Set this flag to return the X2 rotator to its home position (Pan = 
0, Tilt = 0, Roll = 0) upon application exit, before powering down 
the system.  The X2 rotator will always read its position as home 
when powered up, so to maintain a consistent orientation it 
needs to be returned to the home position before powering 
down.  A new home position may be designated with the Set 
Home button on the rotator control dialog.  Any physical 
orientation may be set as Home, but be careful to observe any 
mechanical constraints on rotation when adjusting the Home 
position or changing the user rotation limits. 
 

Detected Keystroke: None  Toolbar Icon: None 
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This flag is set when an X2 rotator is sensed by the DIDSON on 
power-up.  The rotator control dialog is automatically enabled 
(but not launched until requested). 
 

Setup  Keystroke: None  Toolbar Icon: None 
 
This dialog allows selection of the X2/DIDSON mount orientation 
as a Tripod, Pole or ROV configuration.  Check the Set Defaults 
box before clicking one of the buttons to restore maximum range 
on rotation limits for the indicated mount orientation. 
 

Select  Keystroke: None  Toolbar Icon: None 
 

 
 

Use this command to select auxiliary data input via the client PC serial port(s), 
whether physical or mapped as a virtual USB COM port.  The data will be 
stored in the frame headers at the appropriate locations. 

An arbitrary number of NMEA input messages may be multiplexed on a single 
COM port.  All other inputs/controls must have a unique COM port assignment.  
If multiple messages are selected containing the same data (e.g. velocity, 
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heading, water temperature, etc.) then the frame headers will be overwritten 
with message data in alphabetical order. 
 
The command Sonar->Test->Display Debug Data will generate test messages 
which will be output on the indicated COM port. 
 
Setting the Upload Aux Data to Sonar flag will enable the transmission of 
selected aux input data to the sonar with every frame request.  If the sonar is 
operating in Broadcast mode then any active Slave applications will have 
access to the same aux input data as the Master application/PC. 
 
 

Help Menu 
 
Topics  Keystroke: None  Toolbar Icon: None 

 
Display table of contents for online help. 
 

Index  Keystroke: F1 Toolbar Icon: None 
 
Gives brief descriptions of software controls by function. 
 

About   Keystroke: None  Toolbar Icon: None 
DIDSON 

Software version and contact information for help from SMC personnel. 
 

1.2 Sonar controls 
 
Each control has an edit box that allows the user to type in a value or activate the up/down arrow that 
increments/decrements the edit box value. The arrows are activated by a mouse click. When typed, 
the command is executed when Enter on keyboard is pressed. 
 
Frame Rate  Sets the real-time or playback frame rate in frames/s.  Real-time rates are 

limited by the settings of Window Start and Window Length settings. Generally 
the farther the max range, the slower the frame rate due to increased time for 
sound to get to the maximum range and return.  A frame rate is calculated and 
inserted by the program each time the Window Start or Window Length setting 
is changed if the Auto Rate box is checked. The user can modify the suggested 
value. If the frame rate is set too fast, a red square will blink on the lower left 
side of the displayed image. This indicates that a frame has not been received 
within the expected period because the frame rate is set too fast. When the 
computer sets the frame rate, it will monitor late frames and incrementally lower 
the frame rate until frames are kept in sync with frame requests. 
 
Auto Rate adjusts the frame request period in increments smaller of ~2.5%, 
resulting in non-integer frame rate values.  The actual rate is displayed in the 
Header pane, and the Control pane rate will update to a rounded integer 
representation of the true frame rate.  Unchecking Auto Rate will restrict 
operation to integer values for Frame Rate.  A parameter in the frame header 
records the true update period in milliseconds, so that actual frame rates may 
be displayed on file playback.  
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Playback rates may go from 1 to 100 frames/s.  In Playback mode, the cursor 
controls � and � may also be used to control the frame rate (the Shift modifier 
sets the rate increment or decrement factor to 10. 
 

Total Frames  Sets the number of frames to record into the next disk file in real-time mode.  It 
displays the total number of frames in playback mode. The total frames may be 
between 1 and 99999. HOWEVER, you may get a lower number due to 
available disk space on your computer. When you enter a file length, the 
application checks available space and may return with a reduced number of 
allowed frames. 
If Total Frames is set to zero, then the number of frames stored in the current 
file is limited only by disk space available.  Recording will continue into the 
current file until toggled off, or the disk is full. 
 

Receiver Gain  Sets the sonar receiver gain to a relative value between 0 and 40 dB. Displays 
the current value of the receiver gain.  The transmit power cannot be changed. 
It is always at maximum. Reducing the receiver gain instead of transmit power 
is the best way to maintain the best overall signal-to-noise ratio. 
 

Window Start  Sets the beginning range (in meters) of the displayed data. The accepted 
parameters vary from .38m to 11.6m in 0.38m steps in the high frequency mode 
and vary from 0.75m to 23.25m in 0.75m steps for the low frequency mode 
(standard windows), or from .42m to 13.02m in 0.42m steps in the high 
frequency mode and vary from 0.84m to 26.04m in 0.84m steps for the low 
frequency mode (extended windows). These numbers are entered by clicking 
the up or down arrows. Values can be typed as well. The closest legal value will 
replace the typed value. 

 
Window Length  Sets the length of the sector display. The accepted values are listed below 

along with the associated down range resolution and sampling. 
 

 
Standard Length      Range bin length      Fsamp  
(m)            (mm)            (kHz) 
 
36.0 (LF only)  70   10 
18.0 (LF only)  35   20 
9.0    18   41 
4.5    9   83 
2.25 (HF only)  4.5   166 
1.13 (HF only)  2.2   333   
 
Extended Length      Range bin length      Fsamp  
(m)            (mm)            (kHz) 
 
40.0 (LF only)  80   9 
20.0 (LF only)  40   18 
10.0    20   37 
5.0    10   74 
2.5 (HF only)  5   149 
1.25 (HF only)  2.5   298 
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On the sector display, the minimum range is the Window Start setting and the 
maximum range is Window Start + Window Length. 
 

Focus Sets the focus of the sonar. Scales from 1.0 m to Infinity (which is typically 
about 32 m). The sonar will automatically set the focus to the mid-range of the 
selected display window. The operator can override the auto focus by entering 
a new focus parameter. 
 

Auto Freq When checked, the sonar will switch between high frequency and low 
frequency as a function of maximum selected range. The switching point is 15 
m. When not checked, the sonar will stay in the selected HF or LF mode for all 
ranges. 
 

Auto Rate When checked, the sonar will calculate the highest theoretical frame rate for 
any Window Start/Window Length combination, and set the current Frame Rate 
to that value (maximum of 10).  The rate may be adjusted manually up to 30 
frames/sec at any time, subject to acoustic travel time and data 
processing/transfer limitations. 

1.3 Display Controls 
 
Reverse Reverses left and right on the display. This allows the sonar to be mounted right 

side up or up side down on a vehicle or shaft and still maintain correct 
orientation on the display. 

 
Grid Toggles a grid, which is a set of arcs equally spaced in range (0.5 or 1.0 m) and 

radial lines spaced 4° in azimuth. This helps specify the location of an object on 
the display. 

 
Smooth  Selecting Smooth interpolates between the 96 or 48 beams. Depending on the 

display settings, smooth will interpolate and map double or quadruple the 
number of physical beams. If doubled, summing the beams on either side of the 
interpolated line with weights (.50, .50) at each range bin derives the 
interpolated beam. If quadrupled, the three interpolated beams between two 
beams have weights of (.75, .25), (.50, .50), and (.25, .75) of the beam values 
on each side. Interpolation reduces the blocky appearance of the image and 
generally makes it more pleasing to the eye. 
 

Measure  Enables the user to make measurements on, and calculate ranges to, displayed 
objects.  Place the mouse cursor at the upper left corner of a rectangle you 
wish to form around an object or between two objects.  Drag the mouse to the 
lower right corner and release the left button.  A rectangle will remain 
overwritten on the display.  Below the display, you will see the length, width, 
and diagonal of the box expressed in meters with resolution of 0.01 m.  Simply 
clicking the mouse within the display window (without forming a box) will display 
the range to that point, which remains as a yellow dot. 
 

Palette  Changes the display between CRT (blue � white � red), GRAY (black � gray 
� white), LCD (blue � white � red), RED (red � white) and other palettes.  
Clicking View->Palette will display the currently selected palette of colors scaled 
by the Intensity and Threshold values.  Another click on View->Palette will 
return to the sector display. 
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Intensity  Scales the top end of the palette. Values may be changed from 10 dB to 90 dB.  
Decreasing the intensity value will brighten the image.  For example, if Intensity 
is set to 70, echo returns 30 dB below receiver saturation will be displayed in 
the color at the “top” (far right) of the palette. 
 

 On playback the current Intensity setting is replaced with the value found in the 
file data.  The stored setting may be changed by selecting the desired value 
with the control, and then using File�Save As  to rewrite the original data. 
 

Threshold  Scales the bottom end of the palette.  Values may be changed from 0 dB to 80 
dB. Increasing the threshold value  
will remove small returns and noise marks from the image. 
 
On playback the current Threshold setting is replaced with the value found in 
the file data.  The stored setting may be changed by selecting the desired value 
with the control, and then using File�Save As  to rewrite the original data. 
 

1.4 Real-time Mouse Control of the Image Window 
 
When the Sonar->Mouse Extensions flag is set and not in Measure mode, the mouse may be used to 
re-center and/or rescale the data acquisition window.  These actions only work in Demo Mode or 
while the sonar is connected (e.g. not for use during playback). 
 
A simple left-click will re-center the current window length around the clicked (vertical) position in the 
window.  If the end range crosses the crossover point with Auto Freq enabled, then the frequency will 
automatically change to reflect the new end range value. 
 
Left-clicking and dragging will draw a box in the display window.  When the left mouse button is 
released, the window will re-center and zoom in to the closest window length approximating the height 
of the drawn box.  If the sonar is currently in LF mode and the requested window length is less than 
the shortest LF window (5.00m), then the sonar will switch to the 5.00m HF window, assuming that 
Auto Freq is enabled and that the new end range is less than the crossover point. 
 
Right-clicking the mouse will re-center the display window around the clicked (vertical) position and 
zoom out to the next window length.  If Auto Freq is enabled then the sonar will switch to LF when the 
new end range passes the crossover point, even if the window length is available as a HF choice. 
 
These controls may be enabled/disabled with the Sonar->Mouse Extensions flag. 

1.5 File Header 
 
File header information is displayed on the right side of the display window.  In real time, this gives the 
current settings of the system.  In playback it gives the settings when the data were stored.  The 
definitions of the parameters follow: 
 
Identification 
File:   Current file name 
Date:   Date file was made 
Time:   Time (real-time = current, playback = when recorded) 
Header ID:  Text entered by the user when file was made. 
ID1:   (user-labeled) 32-bit integer identifier 
ID2:   (user-labeled) 32-bit integer identifier 
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ID3:   (user-labeled) 32-bit integer identifier 
ID4:   (user-labeled) 32-bit integer identifier 
Rate:   Rate frames were stored in frames/s 
Frames:  Total frames in file 
 
Sonar Status  ( firmware revision ) 
Serial Number: Sonar serial number 
Beams:  Number of beams: 48 (LF) or 96 (HF) 
Samples:  Number of range bins sampled in each beam. 
Smpl Rate:  Sampling rate of down-range samples 
Rcv Gain:  Receiver Gain setting during data collection 
Win Start:  Data window start range in display 
Win Length:  Data window length in display 
Focus:   Focus range in data window 
Frequency:  Sonar frequency 
Sspd:    Assumed sound velocity to determine range of echoes. 
Sonar Pan/Heading: Compass heading (if installed) or pan of sonar from rotator 
Sonar Tilt:  Absolute pitch of sonar (if compass installed) or tilt from rotator 
Sonar Roll:  Roll of sonar from compass (if installed) or rotator 
A/D Temp:  Internal temperature of sonar in Celsius on A/D board 
PS Temp:  Internal temperature of sonar in Celsius on PS board 
Humidity:  Relative humidity of sonar in percent. A leak increases humidity. 
Power: DC voltage at input to sonar Power Supply board. 
 
Platform Status  
Latitude: (filled through Aux->Select or user inserted as type double) 
Longitude: (filled through Aux->Select or user inserted as type double) 
Velocity:: (filled through Aux->Select or user inserted as type float) 
Depth: (filled through Aux->Select or user inserted as type float) 
Heading: (filled through Aux->Select or user inserted as type float) 
Pitch: (filled through Aux->Select or user inserted as type float) 
Roll: (filled through Aux->Select or user inserted as type float) 
Position: (filled through Aux->Select or user inserted as type float) 
Altitude: (filled through Aux->Select or user inserted as type float) 
3D_X: (user inserted as type float) 
3D_Y: (user inserted as type float) 
3D_Z: (user inserted as type float) 
 
 


